Maslow Home Maslow Community Garden Newsletter

Z-axis Safety height not achieved before moving to next cut

I use Easel to create a g-code and them upload that to makerverse V1.1.2. Everything works fine except when the spindle is done cutting one part, it seems to move toward the next part before the spindle fully reaches the safety height. This leaves a ramp cut at the edge every time. I can’t find any reason for it in the g-code. Here is an example of the g-code that was used where the issue occurred:

G1 Z-0.27198 F9.0
G1 X6.41974 Y12.30655 F30.0 …
G0 Z0.25000
G0 X7.07693 Y7.49374
G1 Z-0.09066 F9.0

This happens regardless of a pocket or cut or outside shape cut etc.

Is this a setting in makerverse that can be changed?

can you set the Z move to have F100 or something higher for the Z movement? Or do G1 Z0.25 rather than G0 and then do the G0 X-Y move. It might serve as a workaround, but doesn’t address the heart of the issue.

Is this a setting inside of Makerverse or Easel? I can manually change those, but that would take a long time

You would open the gcode with a text editor and use a find/replace operation. Very manual, very inefficient, but possible for testing to see if that will help ferret out the problem.

That’s odd behavior. Mine goes all the way up before moving.

Here’s what my g-code looks like when moving locations. Generated using easel
G1 X5.45999 Y28.66959 F30.0 (ends the section)
G1 Z0.25000 F20.0 (here’s where is raises up to safety height)
G0 X5.57498 Y23.33041 (moves to new location)
G1 Z-0.12500 F20.0 (lowers to cut again)
G1 X5.52383 Y23.34070 F30.0 (starts to move)

It could be the F20 which is causing trouble. Depending on which z-axis design you are using it might not be able to move that fast.