Maslow Home Maslow Community Garden Newsletter

Acting strange when trying to calibrate

so i ran a test cut to start calibration. it completed the cut i went into the calibration controls and followed there instructions. 254mm square cut 254mm x and 241mm y saved. now it cuts my square about 30 deg off. i try to move y up to measure correctly and it moves about 400mm and stops and changes direction and the controls maintain that direction until i move about 400mm more and it changes (y+ changes to y-) direction again… what am i not seeing in setup?

sorry
windows 10 using easel for g code generation and makerverse for controls. and its a m2 kit. delivered last week.

@makermade do you guys have any thoughts?

think there will be any issues if i reinstall firmware? was considering if there was a button issue? Maybe one of the buttons is programed wrong so its introducing a cumulative error. the initial calibration cut had the correct orientation. and seems like each calibration introduces larger error. i calibrated with a 254mm square. it cut thefirst square 254 x and 241 y. i went through the calibration procedure and second cut was 235 x and 155 y but was wrong orientation to square. i didn’t notice any issues with the large movement changing direction, then i went through the calibration procedure again. it cut a square of 257mm x and 232 mm y then i found the direction change issues and so i stopped before i possibly damaged anything. each successive calibration cut it square to itself but rotating to the material.

between the second and third calibration cut i rechecked and confirmed the rest of my calibrations were correct ie: motor width measurements etc.

Nope, you should be safe to do that. Keep in mind that some settings are stored in the EEPROM which won’t be erased by reinstalling the firmware. It’s possible that updating it will make the issue go away.

I’m not personally familiar with that calibration routine so I can’t help much :confused:

in the console, $RST=* will reset the eeprom settings. Make sure to put the chains close to center and “home” it before doing anything else if you opt to use that command.

k thanks i’ll give it a whirl

So I reflashed the arduino. It corrected the issue with the direction change but its still cutting 30 deg off square. the reset code $RST=* came back as error:3 (invalid statement)
I Purchased a metric tape measure and used it to run through all the calibrations again. it isn’t a lazy motor problem because if i tell it to cut my file it uses the same line. i unplugged the motor cables and usb and reinserted them to make sure they were all seated correctly. still cuts at a rotation. Thoughts?

@smith160 I’m seeing a similar issue. I haven’t found a solution yet but I’ve done some troubleshooting. I switched back to Maslow CNC hardware to rule out any hardware issues… went back to using the DUO arduino and Groundcontrol and both motors are working fine. Can cut straight across the x-axis with that program/hardware.

I noticed that my lines are closer to level when I home the device (both true home and temporary work home). I don’t know if that is the right way to troubleshoot, but just wanted to share what I’ve done to see if it helps us find the right solution.

this really sounds like you homed the machine off center. I did that and it cut 15 degrees off. The machine home and the work home were the issue for me. The machine home never changes, but the work home can move depending on the drawing origin. I tried to cut a sign that was 3’ wide on my 4’ machine and the origin was the lower left, so I moved the sled to the left and set the machine home. The machine thought I recalibrated and thought the sled was in the middle, so everything was too far off. I should have set the work home on the left and never moved the machine home because that then requires a recalibration. The resulting skewed cuts sound similar to what you are seeing. The solution is to find dead center and rehome and rezero everything.

Thank you I’ll give that a try, honestly never considered the center home vs the work home difference would change the calibration. i’ve worked cnc before plasma routers lasers and this will be the first i’ve run into this issue. but of course they were all horizontal.

@huntdunbar with my machine the lines are coming out square to itself so my square has square corners. the square itself is rotated about 30 degrees. i do appreciate the work and info you’ve passed along. if you were to cut the same item 2x with the same home does it cut the same lines? just wondering if you maybe have something slipping? maybe grub screws have loosened ever so slightly. I’m more than happy to compare notes and maybe we can stumble onto the correction together. I’ve been a fabricator and then mechanic for 25+ years sometimes unrelated experience helps come up with “out of the box” solutions. How "used " is your router bit?

so i rehomed in the center of my work space. seems to have corrected my rotation problem. how do i change home for the work? i played with a few of the buttons on screen and a few dont function.

i got off my lazy behind and found the rehome info i needed. thank you to those that gave me help, much appreciated. I usually steer clear of forums due to the caustic environment but this forum is fantastic. thank you!

So for anyone that has gone looking fr help and found this group of posts. I corrected my issue by centering the sled in my work space and setting home. if you set your home low it will cause your item to be skewed off.

3 Likes