Maslow Home Maslow Community Garden

Advice for Metric use of MakerCam

makercam

#1

The online version of MakerCam is not recommended for Metric (mm).
It produces up to 16 digits after the decimal and that has lead to problems with ‘buffer-overflows’ in the past, with MaslowCNC and GRBL.
Although this issue was discovers a while back and we assume it has been fixed on our side, my recommendation is not to start with a g-code like that.

Offline version is crashing*.
The ‘offline-version / local’ has that fixed (other bugs where fixed as well) with the latest git-version (commit 25 Oct 2013) that sadly never made it online.
A local version also has the advantage that if your workshop with the MaslowCNC is off the gird and you are missing a small spacer or something, you can quickly create it without the internet.

Instructions if you choose to:
- Download the ‘ZIP’ from the link below with the green button, to a folder where you will find it.
- Find the ‘ZIP’ you downloaded and unpack/unzip/extract it into a folder from where you will use it.
- To use, navigate to the folder that you have un-zipped the file to and change to the directory ‘build’.
You will find a ‘partkam.html’ that you can open with your favourite (flash-enabled) browser.
(If you have ‘.swf-players’, they might work with the swf-file)

Offline MakerCam: (crashes!)
https://github.com/shapeoko/makercam

Disclaimer: SWFlash (.swf) can be a security risk, online and offline. Make sure it comes from a trusted source.

*Edit: Since the offline version crashes on various occasions the recommendation is to use Inch.
If you use metric and notice an interruption in the execution of the cut or other ‘strange things’, you can try if turning truncation on in GroundControl solves the matter.
-> Go to settings, click on Maslow Settings to access the Advanced Settings and turn on -> Truncate Floating Point Numbers (default is off).

Edit2 (1 more option):
Someone has written a .py script to fix the issue GRBL had with the metric numbers from makercam.
I have NOT TESTED it: https://github.com/jhessig/metric-gcode-truncator


Table of Contents
Makercam scale issue
MakerCAM Plugin?
#2

Just a warning, that version of makercam seems to crash if you do a default profile operation without changing any of the settings, and it doesn’t save any of your work, so you’ll want to save your layout as a svg before you start creating toolpaths.


#3

Confirmed on Ubuntu Mate. Never tried not changing anything. Good catch.

The ‘not saving work’ is the same as the online.


#4

It doesnt just crash on default, it can crash when ever :frowning:


#5

Thanks for the feedback @Jatt and @architectureunknown!
I’ve edited the post according to your feedback.

The reason that I would like to keep the post/warning up, is 2 recent reported troubleshoot errors that could not been tracked down to what had happened. Both had in common that the g-code was from metric makercam use and had the up to 16 digits after the decimal.
If you can confirm that a ‘full sheet cut’ goes well without turning truncation on, I will delete the post altogether.
For the moment my doubt that it’s a good idea to ‘stress-test’ the Arduino with this numbers is enough for me to keep the post up.


#6

There is a fork that seems to not have these crashing issues, I’ve tested it a bit.
the fork is located at https://github.com/kosme/makercam

I’ve made a live version if people want to test it at http://maslowmakercam.000webhostapp.com/partkam2.swf

So far I haven’t managed to make it crash.


#7

The local version still crashes for me, BUT !!! Online, the metric numbers are solved in this version! Great find.
image
vs.


#8

Thats great, tho mine is still crashing which is a pain. Tho Ive quite a few toolpaths so I wonder is this causing an issue

But so close :slight_smile:


#9

Look at this :slight_smile:


If I copy the partkam.swf from the main folder to overwrite the same file in the ‘build’ folder, the mm bug is fixed and is does not crash locally for me. Please test.

@Jatt Could you exchange the 2 .swf on the web? No need, the mm bug in tabs seems fixed in your online version.


#10

I havent tried the local version - Just been working on the online one from the new build folder. Not sure how to work offline.
mm has def worked which is great. Just getting crashes still tho.

EDIT
Working perfectly

Cheers guys – lets hope she works a dream on the maslow :slight_smile: