Can not calibrate machine

@Joe_Tuxie than you for your diligence. Basically what this shows is it looks like the Mega Arduino is connected and working. We are creating a connection and sending data over it and it is coming back without disconnecting. @bar This tells me on a simplistic level the Arduino is working, the USB cable is working. So I want to say there could be an issue with the Shield or the Power.

Thank you

I disagree! This doesn’t look normal at all, we shouldn’t be seeing “buffer overflow”, that means the Arduino is receiving some sort of junk which is filling up the buffer so that the machine can’t send commands…this is very helpful.

Now if only I knew what it meant…why would the buffer be receiving all this junk…did you by any chance send a bunch of ‘B’ characters?

Can you try changing that drop down which says “no line ending” to '\n? (that way the machine will be able to recognize the end of each command that you send)

1 Like

Loopback Test for Arduino Uno

Per the loopback test it needs to be set forced in the reset loop. Which is what is happening when he is holding reset -

1.)Force the processor to remain in reset by connecting a jumper from RESET to GND(black wire in photo).

I’d have to test this without the reset jumper but having input tied to output means it would continuously send it’s self anything it saw in the buffer until the buffer overflows and it would happen pretty fast. I think that is what is happening. Regardless to be able to see this we are getting an uninterrupted seriail connection over USB or we wouldn’t be able to see the monitor.

Thank you

I will attempt these two suggestions and get back with you guys on the results. I really appreciate everyone helping me with this issue.

2 Likes

@Joe_Tuxie

I’m attaching a picture of how to set the 2nd wire on the mega Arduino here. The red line at the bottom of the picture.

Thank you

Quick update. Maslow is sending me a new motor and Arduino. I will update when those come in. Hopefully can eliminate issues with those when they arrive.

5 Likes

So I just received the new parts for the CNC. Thank you very much Maslow team! You guys were great. I don’t know what combination of components fixed my issue, but I was successful in the motor test. I have a strong suspicion that the motor shield may be a culprit. I will now attempt the calibration and set up. Thank you so much everyone for your time and help, it was greatly appreciated!

4 Likes

Joe,

Thank you for the follow up. It is really helpful to know the outcome.

Thank you

Hi guys!, apparently I’m in the same situation as Joe_Tuxie


I tried a different USB cable and every USB port on the laptop and other pc. When Ground control test the left motor it passes just fine and then when tries to test the right motor I get the “connection timed out” Error. I switch the cables from port 3 controlling the left motor, to port 3 controlling the right motor. I obtained the same result; every time I test the motors the motor that is connected to the port 3 moves accordantly. I haven’t try to do that switch with the z- axis motor. Also when I try to orient the sprocket, I’m able to do it on any motor connected to port 3, not receiving any response from the other (It doesn’t move), and I don’t seem to loose connection.
The power supply is plugged into the motor controller shield and not the Arduino.
The Arduino IDE program isn’t running at the same time as Ground Control.
I’ve installed the Firmware-1.10 correctly several times.
it stays connected as long as you don’t try to make the motor turn.
I have an amber light inside blinking continually.

I just don’t know what to do. Thanks for your time.
Mandrake.

I never was quite sure what the culprit was, but I had a very strong suspicion it was the motor shield. The guys at Maslow were super helpful and sent me another one.

1 Like

That sounds like the there is something shorted on the motor shield to me. If you send an email with your address to info@maslowcnc.com we’ll send you a new one right away! Sorry for the trouble!

2 Likes

Bar:

I’ve got the same disconnection issue above. I’ve tried all the suggestions in the forums here including the blink test, EEPROM wipes and full firmware reinstalls and still getting the connected disconnected issue discussed here after testing the motors. I went through the other thread about testing and viewing com traffic and the Arduino checks out fine. Do you think my shield is cooked?

These forums are great. Thanks to everyone for pitching in, ive learned a great deal so far :sunglasses::+1:t4:

D

2 Likes

I think that sounds like the best first thing to change. It sounds like it’s been a good fix for the solution above.

If you email you address to info@maslowcnc.com we’ll get a new one sent out to you first thing in the morning.

I’m sorry for the trouble! Great debugging and problem solving to identify what was going on.

1 Like

For a future revision of the motor board, I would suggest adding some LEDs on
the outputs from the arduino and instructions for how to hook up a LED in
parallel with the motor (instructions rather than built-in LEDs since the motors
could run on one of several voltages)

in cases like this, a simple test program would let us see if the input and
output LEDs blink together, if not, dead board.

This can be done manually, but it’s a lot more work.

Hey guys. Made an account to post that I am having the same issue.
I tried a different USB cable and every USB port on my laptop as well as 2 other pc’s. I tried Ubuntu 14.04, Ubuntu 16.04, and Windows 10. I have installed Kivy from source and from apt-get; as well as using the pre-bundled windows package.
I’ve tried Ground Control 1.13 and 1.14 on the ubuntu machines, and the pre-compiled GC 1.13 on Windows.

The weird behavior is that the left motor almost always passes both directional checks just fine and then when tries to test the right motor I get the “connection timed out” error. Switching cables around shows that both motors work, and oddly I can sometimes ‘complete’ the check (reporting failed status for the Right motor) by disconnecting the right motor and connecting it into the Z position (meaning the left and Z positions are connected).

I am not able to orient the sprocket at all, and I can manually use the arrows on the main GC menu to move the left motor exactly ONE time before it throws the connection timed out. After the automatic reconnect nothing works (including re-running the motor tests) until i’ve restarted Ground Control.

I’ve even fired up the serial monitor that the arduino IDE has and things seem to be working fine.

Just to cover the standard assertions:
The power supply is plugged into the shield and not the Arduino (the top most plug).
I have used both the provided USB-B cable as well as one from a functioning printer that I had spare.
The Arduino IDE program isn’t running at the same time as Ground Control.
I am using the same version of Ground Control as the firmware, and in one case I even used GC1.14 with the 1.13 firmware.
The Firmware 1.13 is installed correctly, using the correct settings. I’ve even installed the blink program (erasing the firmware) verified it works, and then overwritten the blink program with the frimware again, just in case. I downloaded and hashed the firmware multiple times to verify it was correct.

The connection seems to remain stable if you don’t send any commands to turn the motors (not exactly useful this way).

I suspect either the arduino or the shield to have some malfunction. Should I also contact "info@maslowcnc.com" ?

Cheers

1 Like

@Kyle_C Welcome. I’m sorry you’re having issues. I’m sure others will weigh in at some point but I wanted to ask if you have tried uploading another sketch like Blink to the Arduino.

I have more diagnostics here:

https://www.disciplesofcnc.com/wiki/pmwiki.php?n=Site.ArduinoProblems

This could help eliminate Arduino issue.

Thank you

Hey Bee,
I have tried uploading the Blink sketch to the arduino (i used this one: https://www.arduino.cc/en/Tutorial/Blink) ; as well as reloading the firmware several times.

I’ll run through the link you sent and see if anything helps. Thanks for the help!

Is the right motor&cable pair ‘poison’? Would the problem move to the left motor if the cables were swapped?

Yes! We will send you a new arduino shield right away. It sounds like you did an excellent job of testing everything and that sounds like the culprit to me.