Code 43 in Windows 10

I have used my maslow for a few projects, then had to move it into a shed. Now, when I plug my USB cable in, I get a Windows Code 43 error in Device Manager.

Windows has stopped this device because it has reported problems. (Code 43)

Apparently this is a generic error message in software that basically means the hardware’s borked.

Does anyone have any advice on how I can see exactly what is wrong with the hardware, or how to fix it?

Suddenly, my Maslow doesn’t seem so cheap when I only got to make one useful thing out of it… :frowning:

(And it looks like I won’t get my CnC made halloween decorations this year… )

Is it possible that when moving, the 12V power got plugged into the Arduino instead of the Maslow board?

Take a look at the results from Googling “Arduino Windows Code 43”. Hope you get back up and cutting soon :slight_smile:

I wish it was that simple! :slight_smile:

Also, I DID do that when I first set it up, and didn’t get a 43 from that mistake (everything looked correct, but the motors did nothing, as they weren’t getting power).

Yeah, the almighty googles aren’t helping me this time around. I’ve done all the obvious things (deleting drivers, changing cables, etc)

That driver is installed during the Arduino software installation. Something to try might be a full uninstall/install of the Arduino software. There may be a way to only deal with the driver, but I’m not that up on Windows operations.

Another thing that might happen is frying the USB chip on the Mega (voice of experience, here). When that happens, you could use a separate USB-Serial adapter to talk to the Mega over the Tx and Rx pins, even program it over that channel. That would use a different driver for the USB-Serial adapter. You could check whether one of the known repairs is applicable. Or replace the damaged Mega.

Hey Rich,

First thing I would do would be to delete the device from device manager, turn the Maslow off, reboot the PC, plug the Maslow into a different USB socket and power it back up.

If that doesn’t work: Using device manager, delete the driver and the device. Power down Maslow, unplug, reboot PC and reattach Maslow, then power on. You should be prompted to reload the driver. If not, that doesn’t necessarily indicate a failed arduino. Windows and serial USB is a can of worms.

Are you using a generic arduino or a genuine one?

What version of Windows? Please don’t say 8! :slight_smile:

Have you got another computer you can plug your arduino into to test it? You won’t need the shield. Do you have a spare arduino you can use to test your PC?

If you observed normal electronic considerations when moving (power down PC and Maslow before disconnecting, connect and boot PC before powering up Maslow), the chance of is being toast is fairly low, it’s much more likely to be an issue with drivers and ports.

Let us know your findings and any other relevant info.

Sorry, I didn’t see this before replying… you plugged 12v into your arduino? That’s within spec and something many of us have done… and it looks like you’ve tried much of what I said, but my experience with my fathers windows pc and serial USB has been that it’s a nightmare. Windows 10 has improved things a lot.

Have you checked ‘hidden devices’?

  1. Start, All Programs, Accessories, Right-click “Command Prompt” in Accessories and choose “Run as Administrator”
  2. Enter “set devmgr_show_nonpresent_devices=1″ – without the quotes
  3. Enter “start devmgmt.msc”
  4. In the box that opens, select “Show hidden devices” in the ‘view’ menu.

the 12v need to be plugged into the motor shield, not into the arduino. If you
plug it into the arduino, it will power up, but the maslow will not work.

Further… after going through a couple of hundred Arduino of various vintage over the years, my Dad and I realised not all are created equal.

We bought one of each of genuine Arduino to use as reference units.

Often situations would occur that, when we swapped out our clone for genuine, would go away.

I would recommend, for reliability, getting at least one Genuino. They are built better.

For genuine licenced cheaper ones, Seeedstudio in China used to be the go-to, but it looks like they are discontinued. And genuine ones are out of stock at

But, there’s a raft of pin and compiler-compatible Mega-sized units that may suit and you won’t have to mortgage your first-born to get one.

@Rich - Did you problem ever get solved?

I haven’t had a chance to try again. Unfortunately work happens :stuck_out_tongue:

I totally understand - with USB it can be tricky, the USB standard has a lot going on in the background. Most of the time it’s all transparent. I’m going to toss some simple troubleshooting suggestions here. Forgive me if I’m repeating others. First if possible try a different computer. 2nd try a different USB cable. If these are available to you it will narrow it down fast. Update us when you have time to check it out again.


1 Like

So, did this ever get resolved?

I tried to install a sound driver and while installing, I found an error which stated as windows has stopped this device because it has reported problems. (code 43). When I browsed then I acknowledge that Code 43 normally means that the required device is unidentifiable. There are multiple solutions to fix this problem.

1- Sometimes the graphics card is not inserted correctly and cause this error. You need to check the graphics card and it should be inserted correctly.

2- Uninstalling Lucid VIRTU MVP Software, may help to fix this error.

3- You must install the latest Windows Update. Because Windows latest update help to update the system and drivers.

4- You can also update your BIOS.

5- Installing Default Graphics Drivers Above possible methods are the best methods which help to get rid of this error.