Com. Garden upload error with (.zip) (Solved)

Archive: /var/www/html/uploads/userUpload.zip inflating: /var/www/html/uploads/Lift-desk0-2-b.jpg inflating: /var/www/html/uploads/lift-desk2.0final.dxf inflating: /var/www/html/uploads/liftdesk.stl Adding GitHub User: GeroBH GIT URL:> https://github.com/MaslowCommunityGarden/Lift-Desk-Light---Project-upload-Test <— Congratulations! Your project is has been created and will appear soon

is what I get.

The error from @geeklimit is

unzip: cannot find or open /var/www/html/uploads/userUpload.zip, /var/www/html/uploads/userUpload.zip.zip or /var/www/html/uploads/userUpload.zip.ZIP. rm: cannot remove ‘/var/www/html/uploads/userUpload.zip’: No such file or directory Oh darn, something went wrong in the python code… 422 {u’documentation_url’: u’https://developer.github.com/v3/repos/#create’, u’message’: u’Repository creation failed.’, u’errors’: [{u’field’: u’name’, u’code’: u’missing_field’, u’resource’: u’Repository’}, {u’field’: u’name’, u’message’: u’name is too short (minimum is 1 character)’, u’code’: u’custom’, u’resource’: u’Repository’}]} /var/www/html/createRepo.sh: line 12: cd: /var/www/html/uploads/tmp: No such file or directory deleting usrinput.txt”

1 Like

My zip only included 12 .jpg files, and the main pic was a .jpg.

Not sure what else I could have done differently.

The title and description might have has special characters, but I can’t remember exactly now ( :frowning: )

@geeklimit Are you logged into GitHub and have excepted both invitations?

I’m logged into github and see no invitations or notifications, no new repo’s in dashboard

And you linked the .jpg cklicking on the first ‘browse’ and the .zip on the second?
are you logged in during creating a new project? And the garden asks for you GitHub name.

Yep, I was logged in, chose jpg as pic, chose zip, gave it it a title, description and entered this for github name: geeklimit

So from that side it looks alright. Have you tried moving the .zip file and checking the user right settings for the file and folder. What operating system are you running?

Need to find out why this is in the log…

right.

I checked github by making a change to one of the files in one of my repo’s, it’s OK.

The test I did does not show on my account either, as I made it open for community. It showed up here:
https://github.com/MaslowCommunityGarden

Yes, I chose the ‘I want to manage’ option.

And I don’t see the project I tried to set up in there.

Maybe I’ll try making it with no .zip? Wish I remember what my title was, I liked it :slight_smile:

Need to find out why the ‘No such file or directory’ is in the log. I’m running out of ideas. The experts will jump in here soon. No worries, this gets sorted out.

Do you have enough user rights to upload the .zip here?

OK. just tried again. It seems like it uploads, then fails. For troubleshooting:

What was submitted:

What it shows after it’s done uploading:

On Windows 10, using Chrome Version 66.0.3359.181 (Official Build) (64-bit)

1 Like

It looks like I’m allowed to upload here in the forums, but it doesn’t like the zip file.

“Sorry, that file is too big (maximum size is 3072kb)”

I don’t really have files for this project, so it’s a .zip of pictures 10x bigger than that limit

Test upload of a jpg:

Try changing the file names. There are a lot of > . < in there. Not sure, a blind try.
If it’s just the name of the main picture, you buy me 1 beer :smile:

OK. New test, I’m guessing zip size.

1 Like

Do you have a drobbox or an other place tp park the. zip (if that does not invade)

Here in the forum, but what is it with Git? If it is only .jpg it is worth to downscale them on what is optimum for display and try with a smaller .zip. If your touching them anyway, make the names short, simple and descriptive if you have the time :wink:

I copy-pasted the instructions test from my thread into a .txt file, and made a .zip out of that. Works fine.

email invite received from github 2x:

and in github, OK:

1 Like