Community Garden Broken?

I just tried to upload my first project to the community garden. Think something happened, as now i don’t see any projects now, or sometimes one will show up randomly and then go again?

Also tried on a different computer and looks the same?

1 Like

I’m having some issues with github at the moment and github is the backend for the community garden (I believe).

Ahh ok, i was having trouble with Github myself yesterday trying to create a user account, I got these python errors if it helps?

Log from the python script which creates the github repo:
unzip: cannot find or open /var/www/html/uploads/, /var/www/html/uploads/ or /var/www/html/uploads/ rm: cannot remove ‘/var/www/html/uploads/’: No such file or directory Traceback (most recent call last): File “”, line 48, in org = g.get_organization(‘MaslowCommunityGarden’) File “/usr/local/lib/python2.7/dist-packages/github/”, line 198, in get_organization “/orgs/” + login File “/usr/local/lib/python2.7/dist-packages/github/”, line 169, in requestJsonAndCheck return self.__check(*self.requestJson(verb, url, parameters, headers, input, cnx)) File “/usr/local/lib/python2.7/dist-packages/github/”, line 182, in __check raise self.__createException(status, responseHeaders, output) github.GithubException.GithubException: 502 {u’message’: u’Server Error’} /var/www/html/ line 12: cd: /var/www/html/uploads/tmp: No such file or directory deleting usrinput.txt deleting mainpicture.jpg

1 Like

Hmmm that seems like an issue with the website not accepting the zip file correctly. Would you be willing to attach the zip file here so that I can try to duplicate what is going wrong?

I did get an email saying that the community garden website server couldn’t reach github about 10 min ago so it might have just been bad timing

1 Like

Sure, but i did manage to submit it from my home computer. Still got a little error but i see it in the garden now. (2.6 MB)