Connecting Maslow4 to your home WiFi - User Guide

Just appears like magic when I hit save lol

1 Like

:joy: I have never seen that before. I guess your text editor is adding it?

The good news is that if you update to v0.67 which was just released seconds ago you don’t need to edit your .yaml file in a text editor anymore. You can edit it directly in the settings and save it.

I haven’t written the documentation in the user guide for how to use it yet though…that should be up in the next hour or two

If you give me a how to I can be your crash test dummy!

It’s quite a bit more straight forward…which is good because the old way had way too many opportunities for something to go wrong (like a .html appearing)

Click on FluidNC at the top, then Config Items and then you can edit your settings and press set. When you like your values press Save and they will get saved to your maslow.yaml file automatically.

No need to restart or do the Retract All → Extend All process between changes

I will try it, now I was able to get the blocking red lights off. I tried to move the Z axis down… Looks like the computer thinks it’s down but it never moved.

Hmmm…Turning it off and back on again might fix that

Nope. I will wait till you have a video or documentation. Not sure how to upgrade to the new firmware. Lol

1 Like

The documentation for updating the firmware should be up to date still, you can find it here: User Guide — Maslow

So I got the firmware updated…I see the same button now. But got a list of errors. I got 2 belts to retract but that’s it. And the Z axis motors are pretty warm.

1 Like

Does everything look OK with the connection to the top right encoder? That error message to me looks like that Ethernet cable might need to be checked.

Have no idea of what’s going on. In the picture I have a green light on all 4 arms but only yellow lights on only 2 arms. The control board on to of the router has all 4 green lights and all 4 yellow lights will blink.

1 Like

That is totally normal. The green lights show that the encoders have power. The yellow lights will come on and off with the encoder position. If you push some belt back past the roller you will see the yellow lights blink on and off.

Z axis will not go up or down and I can only get 3 belts to retract. I tried to extend all but afraid to break them… Tried to give a tug like you suggest but get all kinds of alarms on screen.

1 Like

What kind of alarms are you getting?

This is what I get as soon as I turn it on and connect.

Then once I go in and hit retract all…I get this.

1 Like

That looks pretty much normal to me. That error message about not being able to connect to the SD card is an issue, but I’ve seen that before and it usually goes away with turning things off and back on. Other than that everything looks normal.

To get that third belt to retract lets try increasing the amount of power that it uses to retract them.

You can do that by clicking on FluidNC and then on Config Items

The number that we want to change is this one:

To unlock the Z-axis click on that red Alarm button and it will unlock.

What should I change it to?

Great question. I would start with 1500 and if that doesn’t work go up to 1800.

Pressing “set” next to the number after changing it will update the value so then you can retry Retract All to see if that value is high enough. Once it’s working press Save at the top of that page to store the settings so that they will be correct next time you turn the machine off and back on