Maslow Home Maslow Community Garden

Corrupted firmware/groundcontrol using different versions weird G2/G3 cuts

groundcontrol
firmware

#21

FWW - The last test I ran was on FW 1.23 with GC 1.22. I saw no issues. Has anyone tried going back to GC /FW 1.22?

Thank you


#22

OK, The issue is fixed for me. Uploaded the firmware provided by @blurfl in this post and ran my test gcode. Everything came out as expected.


The cut on left went clockwise and the right one went counter clockwise.

This was not an issue for me. Did not get any errors compiling or uploading the firmware.

AFAIK Firmware and GroundControl must match version numbers as various new features must be implemented simultaeously in both. My calibration settings did not transfer during initial update from 1.22 to 1.24 and I could not move sled without errors. Wiping EEPROM destroys all saved settings, so is a good fresh start, but requires recalibration and checking all Groundcontrol settings. e.g. Advanced settings -> Position Error Limit: Was not correct. This setting does not appear to be stored in the groundcontrol.ini and may be stored in EEPROM.

I could not downgrade. Arduino IDE reported sucessfully upload but the board would reboot keeping 1.24. I think this is why @blurfl suggested doing the EEPROM wipe before downgrading but I did not try this as I found a workaround in Fusion360.


#23

Thanks for testing the fix. I think it’s ready for a release.


#24

Yes, totally agree this fix should be released, as it addresses a critical flaw, that has been completed fixed, and confirmed by multiple sources.

Might also want to add a warning to the 1.24 version, about known G2 code issue, so that people do not inadvertently use it.

Thanks for the prompt fix @blurfl and sorry for taking so long to test it.


#25

I’m sorry for the delay guys, I was camping with my mother and had very intermittent internet connection. The fix is now released!


#26

Thx all for the fix


#27

Hi Bar

Ive downloaded the latest 1.8.8 Arduino zip and the latest firmware 1.2.5, and after I extract the zip files and go into the Arduino folder to initiate the exe file, Im getting a dialogue box with request to continue using app or choose another, but nothing works? the exe file never brings up the Arduino gui so I can set my com port and upload? Any guess? Windows 10.


#28

There are many install method of Arduino IDE. If you used the Windows ZIP file You will need to extract it to a folder then in ‘Arduino-1.8.8’ folder run the ‘arduino.exe’ file to bring up the GUI.

Then do File -> Open and browse to the folder with the firmware. Then in there go to folder ‘cnc_ctrl_v1’ and open ‘cnc_ctrl_v1.ino’. You can then set your port, speed, and upload the firmware.

If this does not work please provide

  • Links to files you downloaded
  • Screenshots of errors