Maslow Home Maslow Community Garden Newsletter

DUE v1.2 Control Board No Power to Right Motor

Hello

I am ready to calibrate my M2 and discovered that I have a problem with my DUE v1.2 Control Board, at least that is what I think.

The issue: No power to the right motor.

What did I do to determine this?
Left Motor has power and the Z Axis motor has power. I can hear the “whine” of the power when I plug in the control board and I am able to control both the left motor and z axis motor in makerverse 1.0.6. while trying to calibrate.

The Right Motor works but does not get power from the Control Board.
I can power the right motor simply by switching the cord and plugging it into the left motor cable port.
Other than confirming the motor gets power and the cord is good this does not help me.

Is there something I am missing in the makerverse app?
Is there potentially an issue with my USB to micro usb?

Any assistance or insight into this would be greatly appreciated!

Mike V

Two additional bits of info:

In my attempts to center the router on my workspace the right motor will intermittently work but only when I try to move the router to the right and rapidly click the X+ button. No matter what it will not move left, up or down.

In addition it appears power is going to the right motor until I open CNCjs or Makerverse at which point the power goes off at the right motor.

Maybe this is an app issue?

above is firmware if you want to reinstall, not sure that is the issue. I would check the power pins and make sure they are actually supplying power with a mulitmeter.

Thanks Metalmaslow

I confirmed firmware is up to date.

When Makerverse is not running there is power.
I open the Makerverse app there is power.
I open the connection console and unlock there is power.

When I Manually move the machine up, left, down No power.
Manually move the machine right It moves and has power, but only for values above 50mm.

Very strange.

First of all, nice testing. You did a thorough job of isolating where the issue is. I think it’s safe to say the problem is either in software or in the controller board.

I don’t think it would be unreasonable to ask MakerMade to send you a new shield. That would be my hunch for the issue. A bad H-Bridge motor driver chip can behave in strange ways.

@makermade do y’all have any suggestions?

Thanks @bar,

I also reinstalled the software and tried earlier versions with same result.

@makermade is sending me a new board. Crossing my fingers that will let me move forward.

I will post the results.

1 Like

New Board = Progress

I was able to go through all the calibration steps successfully.

2 Likes

Fantastic! We’re glad to hear it :grinning: