Maslow Home Maslow Community Garden Newsletter

Left and Z motors run away, Right motor doesn't function at all

This is my first CNC experience and I have been following the videos and instructions the best I can.

Once I assembled everything I watched the calibration video, logged into Makerverse and powered the machine. Every time I try to jog the left motor runs away while the right motor does nothing. The Z motor runs away too. I checked all the connections and the pins and everything looks good.

The Arduino case top was shattered when I removed it from the box. Could the Arduino be damaged or are there settings I can try correct my issues?

Does Makerverse offer any sort of test function for testing the motors and encoders?

I have reached out to Makermade, and haven’t received a response yet. I figured maybe someone here had experienced something similar.

have you “reset chains” (ver 1.1.2) or “home” (ver 1.0.6) the system before trying to jog it? I had the sled go down when I tried to move the z axis the first use without having told it it was home or centered with the reset chains button. If you have already done that and it still goes off on its own, then maybe it is something else, but I had this happen with not just one but two different due controllers on the first use. Which video did you watch?

1 Like

Orob

I reset home, and that did the trick. However, every time I reconnect to the computer the Z axis runs away again… sometimes with a jog, sometimes on it’s own. Per Makermade support I need to unplug the Z axis and reset home, then plug it back in. It works, but I feel like something must be off for me to have to do this every single time I hook my Macbook up to the Arduino.

they told you you have to unplug the z axis every time? They need to fix their firmware if that is the case. What they told you to do is a test method, not a solution.

You are correct in that is the test method. My machine is in the garage but I do most of my work in my office. Every time I reconnect the USB I have to go have the Z motor unplugged and reset home, or the motor will run away.

I’m going to reach out to Makermade support again tomorrow. I will post any solutions they provide.

1 Like

Interested in what you solution is/was…

I apologize if someone has already addressed this. My M2 Ran away as well when I first got it. I had the Z and X plugged in on the shield wrong. Switched the Z and X and worked fine.

Makermade sent me a new Z axis motor, saying that the encoder was bad. I still do not have the system calibrated but that fixed the issue with the z axis.

1 Like

Glad the encoder fixed the issue. Now on to calibrate… Just take it slow and take good measurements.

1 Like