Maslow Home Maslow Community Garden Newsletter

Feature Request: SNKU Warning and Alarm

My mind has been known to drift when in the midst of a long cut. Experience has taught me that the ‘Sled Not Keeping Up’ measures are often a harbinger of failure. I would like to have the option for webcontrol to play sounds when this value exceeds a certain threshold - preferably with 2 steps. The first a sort of gently chime to let you know “Hey - you probably should be paying attention” and then of course the second that is a blaring alarm to tell you to reach for the shutoff.

1 Like

i had this twice in the last 2 cuts… not happy

1 Like

I’m not sure a sound played on the browser would do any good as I don’t think you can hear it over the router/vacuum combination. I wear ear muffs to mute the sound as it is.

However, from a safety perspective, I think it would be wise that after the sled stops, the controller attempts to raise the height of the z-axis to safe height. This keeps the router bit from spinning next to wood in a fixed location.

2 Likes

Ha! Yes - excellent point.

I am often listening to music on the same computer through noise cancelling bluetooth headphones - but I suspect I am an edge case!

It would be great to have some feedback on the screen. I have my cuts stop before for sled not keeping up, but not recently. I don’t know if I am running very well, or borderline getting the error again. So maybe it can display real time if you are keeping up, 10% delay, 50% delay, 90% delay warning, etc.

There’s bar graphs that’s shown in realtime doing that exact thing… you can monitor the error and see if its starting to get out of whack.

image

1 Like

Excellent! I actually am not using Webcontrol yet, but going to make it a priority soon (I just learned it can work on a PC without needing to get a raspberry pi).

1 Like

please be aware that the default ‘sled not keeping up’ settings are FAR too
sensitive.

I am the one who dreamed up this alarm, and in practice it really doesn’t work
as intended. If the feed rate is set too high, the alarm will go off before the
PID loops ramp power up to max

you should make this alarm far less sensitive (or effectively disable it) until
we either change it to alarm when the power is maxed out and still needing to
increase, or we have acceleration planning in place.

David Lang

1 Like

is setting the error to 15 too high?

I generally change it from the default of 2 to 20.

David Lang

should we change the default to 20?

I really think it should be disabled entirely as it is.

David Lang

Could make an additional setting to enable stopping and moving Zaxis to safe height when the error level is reached. If disabled, it just keeps on cutting.

What about making it trigger Pause?

I like the error bars, but I don’t like that it stops.

That makes too much sense :wink:

Great idea!