First time assembly took 14 hours to assemble and does not work

I don’t know where to start - about to pitch the how thing.

there was a cold joint on the PC board. I fixed that. so not such a big deal
following assembly
all but one of the cassete thingys did not work. (1 in 4 worked)

is there no way to bench test each cassette befor fully assembling the thing to deiscover that it does not work???

1 Like

I want to bench test the cassettes before assembly.
can I connect a single cassette to the PC board?
if so what RJ45 goes with what two-pin connector?
thank you.

assembly is quite frustrating for a man with large hands

1 Like

Where was the cold solder? That’s something that I would like to make sure isn’t happening.

I could add a “test” feature to the firmware, but the way it is set up now all four need to be connected or it will not not move any motors.

In what way is the arm not working? What would be needed to be done to test it?

the cold joint was the U25, U26 pins

1 Like

Thank you for catching that and letting us know! I will keep an eye on those.

Well, lets see.
I assembled the unit totally and took it outside to test.
plugged in. connected to the maslow wifi. all good so far.
during assembly, I had to leave the belts out so I wanted to retract the belts.
by the way, the instructions say “setup” but in the app it is “configure”
I tried retract all. nothing happened
I tried retract upper right, left, bottom right, left. only one of the cassetes (arm) worked.
I tried one at a time and eventually. some of them worked - although very slowly

then I tried to release all. and tugged on them. only the one worked properly.
kept playing with it until all of the “arms” extended but would not retract.
all but the good one of the arms extended without being tugged. one of the arms got snarled inside the cassete (arm)

eventually, I started to question if the assembly had gone wrong. if i tighted the cassete (arm) too much.

now I have the whole thing disassembled and am trying to make sure that the parts work properly before i try again.

1 Like

I think it would be helpful to have a “diagnostic” mode where I could plug in each arm in isolation, test extend and retract to make sure the arm (cassette) is functioning properly before assembling the entire unit

2 Likes

After thinking on this for a little bit I have some ideas, but there are still some things that I’m stumped on also.

In particular:

I have no idea what would cause this. Pressing retract all is exactly the right thing to do. Was there anything which is mechanically preventing the gears from rotating? I could see that maybe preventing them from working, but I wouldn’t expect them to be slow.

Updating to the latest firmware and index.html version will fix this and will make the process match the pictures in the User Guide.

While they were extending did it feel like the motors were running smoothly? The only thing that I can think which could cause them to extend but not retract is that retract uses a current threshold to detect when the belt is fully in and the end stop hits so maybe when they are retracting there is something preventing them from rotating smoothly and so they think they are hitting the end stop immediately.

You aren’t the first person that this has happened to. Did this happen from pressing one of the arrow buttons? There will be a fix for that in next week’s firmware update which will disable those buttons until all the belts are fully extended. The gears can mangle the belt when that happens. If you DM me your address I will send you some spares ASAP.

I’m going to build a wooden stand to hold the pieces in place for testing.
also going to order a 2mm hex handled driver. that little allen key is horrible for baseball mitt hands
I’l work on it again once i have a test stand and the hex driver
the belt looks fine to me - but a couple spares would be a good idea. will DM address

1 Like

ok, build my wooden test bench.

Updated the firmware as you can see by the fact that it says “setup” where “configuration” used to be

There is a RED blinking light on the PC board. no morse sequence, just a steady blinking red.

I did notice that on three of the “arms” the RJ45 plug had both a yellow and green light (i forget what that means but I think its just supposed to be green?)
pictures to follow (only allowed one image per post)

in my case, the one with the belt fully retracted, was the one that worked fully in the initial attempt. this time none of the arms did anything when I attempted to send it commands.

not sure what to do next

1 Like

GREEN and YELLOW lights on Arm end of the RJ46 connection

1 Like

Only a green light on this arm

1 Like

interesting - just looked up what the light represent. it would seem that the three arms are getting constant communicaitons. …I’m pretty sure that’s not right. is my PC board bad?

1 Like

Mine seems to be working correctly. Right now it is on and sitting. 1 arm has both lights on. 2 arms have just the green light on. And the remaining arm just the yellow.

My blue light is blinking a sequence.

1 Like

Keep in mind these are not Ethernet ports but rather the parts used in a custom application. The lights mean whatever Bar wants them to.

1 Like

ah. roger that

1 Like

you have a blue light. not a red one? hmmmm… red is ussually bad.

1 Like

Not that’s on. Flashing blue sequence and a solid green. Have you taken a hard look at your controller? A few reports of issues with those during shipping.

1 Like

The red light indicates that the board detects something is wrong usually meaning it thinks that one of the encoders or motors is not plugged in. It only checks once at start up, if you unplug the power and the plug the power back in does the light stay red?

I’m working on the firmware update for this week right now and just wrapping up solving a different issue. I’ll see if I can add something to make debugging that red light easier.