GC 1.06 error code

I just uploaded the new firmware(1.06) and am trying to get going on the stock frame I just put together but I get following error on GC

Please set$12 $13 $19 and $20 to load old position data

Any insights?

While that error will show in the log when you first start, I believe GC should automatically fix everything when it fully boots up. If you restart GC are you still seeing the same error?

2 Likes

Yes 12345678910111213

It comes up for every movement I try

What version were you upgrading from? And I assume you have upgraded both GC and FW (not trying to be insulting… just making certain).

1 Like

I was on 0.96 before on the temp frame. I’v got 1.06 on both GC and the firmware.

Oops. I had the old version of firmware buried in my arduino libraries. I had thrown up all kinds of flags when it first uploaded but dd complete upload. Deleted old folder re-upload and seems fine. Thanks for the time madgizzle

3 Likes

Hmm, I just tried this. I don’t see your error, but sadly it isn’t able to load the sled position which sucks. That wasn’t my intention, let me see if I can figure out how to fix that.

1 Like

Bummer, this is not a simple bug. Something rather complex is occurring that is preventing the old position data from being loaded.

2 Likes

Worked fine after I deleted the old 0.96 firmware from my libraries and reformatted the mega

2 Likes

Good to hear.

The idea is that we should be able to save your sled position data. We seem to be writing to the EEPROM somehow in a manner I was not expecting, still trying to track that down.

2 Likes

I’ve seen ‘strange’ things while I was extracting the new firmware over the current one, some time back.
If I remember correctly, it was something in the line, that obsolete ‘modules’ did not get deleted and the Arduion IDE would force them into the upload. I started renaming the FW and GC folder by version number. Since I extract the new zip into a clean folder, it never happened again.

1 Like

I’m having the same problem too but cannot seem to find what needs to be deleted to make the error go away.

What you download of new version of GC and FW, put in a new folder. Don’t over right pre existing ones.
If you want a clean start, delete the groundcontrol.ini from your home folder and use wipe eeprom from the advanced menu in GC.

I deleted the .ini file and wiped the eeprom in Groundcontrol. Now Groundcontrol doesn’t know what COM port to use and I don’t remember how to set that. Went to Github and tried to follow the instructions… the links are dead: https://github.com/MaslowCNC/GroundControl
(look under “Documentation”)

open Ground Control, go to settings. Comport, select comport, open.

I think -

What OS is on the computer. I’ll do a step by step based on that.

Thank you

1 Like

OK totally wrong on my part, Open Ground Control, Actions. Right side update list, Comport - select, hit connect.

Thank you

2 Likes

Thanks. I fumbled around and found the settings I needed.
It took almost 4 hours but I’m just about up and running again - turns out my Adjustment Button Housing is likely bad for some reason: https://www.ereplacementparts.com/adjustment-button-housing-p-160347.html

1 Like