Gcode Design / nc file not appearing in WebControl when uploading or opening

I am trying to get our Maslow up and running and am finally at the stage where I have my nc file prepared and WebControl connected to the Maslow but when I try to upload or open up the nc file, the design does not appear anywhere on the artboard. I am very new to this so forgive me if I am missing something really simple. I couldn’t find anyone else online having this same issue so I’m not sure what’s going on. I have checked the size of my design and it should be around 15"x15" so it’s not like it’s accidentally so huge that it’s not appearing. I also zoomed out incredibly far and the design isn’t floating off the artboard somewhere. If anyone has any suggestions on things to try I would greatly appreciate it. Thank you!

-edit, it looks like the file is uploaded and will actually cut the design it just isn’t appearing on the artboard in WebControl. I am not sure why it is invisible so now I am just trying to figure out how to get it to appear.

It could be one of a couple things:

  1. where did you prepare the gcode file? Is the origin in the lower left or somewhere off in the ether so your drawing is forever too far away to see?

  2. Is your svg in mm and your nc in inches so it is scaled and too large to see (sounds like you checked this one)

  3. is there an error in your gcode so it doesn’t upload it correctly? Have you tried one of the online simulators to “run” the gcode?

  4. are you running webcontrol as a user in a space that doesn’t have rights to save the gcode file, so it is uploading, but not saving and you can’t load it? after uploading if you go to gcode → open, do you see the file as an option to load?

Not sure if any one of these are relevant. if you want to upload your gcode (not a requirement, some folks prefer not to and that is ok), I could load it on my system to see if it is a gcode error.

1 Like

quick comment, with webcontrol you have to upload your file to get it onto the
pi, then you can open the file that you have uploaded. It’s a two step process

David Lang

Usually after uploading it shows on the workspace immediately on my system.

Hi Orob,

Thanks for responding so quickly. I prepared the svg file in Adobe Illustrator and then took it to KrabzCAM to create the nc file. The design is centered right in the middle of the board on KrabzCAM. Initially I had done it a little off to the right but decided to center it in case that was causing an issue.

My svg is in inches and it was also set to inches in KrabzCAM.

I did run it using NC viewer online and it didn’t come up with any errors or issues. Ultimately I even ran the cut and it cut in the right size and was fine. It just makes things difficult not being able to see the outline/design in WebControl.

Here is a google drive link to it (starmoon_profile_centered.nc - Google Drive)

I am a new user and unfortunately don’t have the ability to upload files directly.

try doing thing in mm, or zoom in a lot in WC to see if it’s importing it in mm
and so is tiny compared to what you are expecting.

David Lang

This is what I see on my phone:

I’m not at the computer right now, but correct me if I’m wrong), if workspace is in the board view (shaded pink) it won’t show the image. Click the board button at the top of the workspace to toggle between views.

it just changes the background to brown instead of gray.

@Orob it is interesting to see that it shows up on your phone for you. I am not sure how to get it onto my phone (android) or if that would even solve the issue. But that at least tells me the file isn’t messed up, so I’m wondering what is going on with my WebControl thats making the design invisible. I was thinking of creating a new design to see if it does it again but since it is showing on your phone I feel that might be pointless. For now I may try that anyways since I am unsure what to try next.

And @TimS I did toggle the board view and nothing changed sadly besides it changing the board from gray to brown.

If any of you have any other suggestions that would be awesome but I understand if not. Sounds like this isn’t a common issue with an easy fix.

-EDIT: So i tried it in ground control and the design is coming up fine. So it seems to be an issue with WebControl.

What version of WC are you running? When you chose the to upload the file do you get a swirling loading circle on screen? Try to view/edit the gcode from within WC after it “loads,” is there code?

May be a Krabzcam issue. I have been meaning to try it out, will this weekend.

I am using v0.94 which should be the latest version. I do get a swirling icon that comes up when I try to upload my file but it is very brief and disappears quickly and when it does, nothing changes and the screen looks the same. When I click “view/edit” it does come up with code.

the design shows if webcontrol loads it. I was just using the web browser on my phone to view it. type in the ip address of the computer running webcontrol with a colon and 5000 and any device should show webcontrol. That was the big deal with webcontrol vs ground control. Groundcontrol only works on the computer running it and webcontrol will work from any computer on the network with a browser.

At first I wondered if you have G3 and G4 code in your file. The older versions of webcontrol choked on those… but I actually think it is the lower case letters. not sure if there is a way you can have krabscam output capital letters? open the file in notepad and use ctrl+h to and find/replace g with G, x with X, y with Y, z with Z, f with F and see if you see it. My version of webcontrol loads it because I fixed that part.

So that actually fixed it! But for some reason it is not appearing smooth like it should be. My circles have turned into octagons and the crescent shape in the inside is no longer smooth and I’m unsure if it’s just appearing this way or if it will actually cut this way. Thanks so much for the advice by the way, it is really relieving to have at least one of the issues I’m experiencing solved.

Hi, could there still be some letters in lowercase maybe…like “i” or “j” perhaps ?
…just guessing…could maybe explain the jagged shapes…

Anyway, KrabzCAM can generate gcode i capital letters.
There is a “Generate uppercase GCode” checkbox in the save-gcode dialog.


1 Like

@Orob, @mkrabset, I have got it all fixed now, the issue was as you both said. At first I took the code into notes and found and replaced all the lowercase letters (more time consuming than I’d like, but it worked).

I eventually did find the “Generate uppercase GCode” checkbox that mkrabset mentioned. It completely fixed all the issues I was having. I had another time where it turned out all messed up because I missed some of the lowercase letters. Using the checkbox on KrabzCAM has fixed all of the issues.

Thanks so much for all the help!!