Gcode stops working after 300 lines

Those are some bizare results aren’t they. It’s not clear if it’s GC or the firmware on the Arduino (or even the Arduino hardware itself) that is crashing, but my 2cents worth is that I did used to experience some random USB-Serial driver stability problems on macOS that could cause jobs to randomly fail part way through like this.

Assuming your gcode itself isn’t the cause (maybe post it to a site somewhere for others to try running (eg Google Drive, pastebin etc) then I’d encourage you to try WebControl on a dedicated Raspberry Pi. That’s how I run my machine now and it’s rock-solid stable. The rpi itself is a headless ‘appliance’ style device attached to the Maslow and my primary user interface is still my macOS device - I just interact with WebControl on the Rpi via a web-browser interface in Chrome or Safari.

1 Like

I thought webcontrol was a windows platform only🤔. How do you use it with a mac os?

Webcontrol is a brwoser based system written in python, it will run anywhere you
can run python.

It’s primary focus is to run on a headless Raspberry Pi that you dedicate to
running your maslow, but you can run it on anything.

David Lang

1 Like

I interact with WebControl on the Rpi via a web-browser interface in Chrome or Safari on my macOS device.

1 Like

does the RPI replace my mega board? I’ll need a little help with this, I never used this before.

it looks like the RPI basically replaces the computer and connects to my mega to run the CNC. If I understand you guys correctly I will install webcontrol on the RPI. and run that from my Mac.

1 Like

I found this, would it be suitable? Raspberry PI 4 Model B with 4GB RAM— Featuring: b/g/n/ac dual band 2.4 GHz and 5 GHz wireless LAN — Bluetooth 5.0 - 2x Speed, 4x Range, 8x Data SIZABLE RAM: This Raspberry Pi 4 comes equipped with 4GB of RAM. Thank you,

1 Like

This is correct.

David Lang

That will do the job very nicely.

David Lang

1 Like

There are some instructions on how to set up the raspberry pi as well as images you can download complete if you don’t want to set it up yourself.

Be aware of the option to upgrade your firmware to holey calibration in webcontrol. It can work beautifully depending on the motor shield (top board) connected to your controller (bottom board). If you have an eastbay shield 1.5, you should not use the version included and use theirs from their website.

1 Like

The board i have is from makers, mega 2560 i think.

the mega 2560 is the brain / processor and the board above it is the motor shield. Each kit supplier has different versions. Yours should be fine to use whatever webcontrol firmware is available.

Hey guys, I received my RPI today. I loaded the image as the instructions said, it was pretty straightforward. Then put the sd card into the RPI and power it up. I waited a few minutes and then tried to login to through my browser, but had no luck. I can’t tell if the RPI is doing anything or not. the only indication on the RPI is a steady red light and a blinking green light. the light pattern is 4 long flashes and 4 fast flashes. I did set the wifi up in the config file (I don’t remember its name).

can you hook the pi up to a HDMI monitor to make sure that it’s booting up
properly? you don’t need to have it hooked up to the maslow for this.

David Lang

1 Like

okay, I hooked it up to an HDMI monitor. It said it was not compatible with this version of pi. and pi needed to be updated. So I made a new pi boot disk and installed it on the board, and it booted just fine. The wifi is working too. I hooked a USB mouse and keyboard up so I could move around. can I download webcontrol to the pi and install it? or is there a newer image for RPI 4b with webcontrol on it?

Thank you,

@edknue Here is an article that @Orob put together for getting webcontrol onto the RPi: WebControl Setup on Raspberry Pi

Also, here is another post where there was some troubleshooting and whatnot to get someone else set up. It kind of starts in the middle, but just keep reading down through the posts and it should get you there. Help needed loading Webcontrol on RPi - #31 by c00nphrog

I hope this helps you get set up in some way.


Hey guys, I made a lot of progress, I have been reading all of the postings you all have suggested and gotten wecontrol loaded and working on the pi. Where I seem to be stuck now is the auto lunch when I boot the system. I followed orob’s instructions as follows:

$ sudo nano /etc/systemd/system/Maslow.service.


I changed pi to knuecnc in the dictionaries. then save it.

$ sudo systemctl start Maslow

$ sudo systemctl enable Maslow

When I reboot, webcontrol does not reload.

Any ideals as to what I’m doing worng? Thank you for all your help!!

If you change the user folder to knuecnc, then change the service line



User = knuecnc

Is there any response text after you start the service?

What do you see if you use this command after starting the service?

sudo systemctl status webcontrol

it’s amazing what one-word “status” can you.
I changed pi to knuecnc in the user name. Then did the status check as you requested, and right then and there in big bold letters, it told me I was a bonehead! I was trying to use Maslow.service and it was looking for webcotrol.service. I made a new file called webcontrol.service copied and pasted everything from the old one, saved it launch it and it worked perfectly! I then enable it, shut down RPI then turned it back on. after it booted I was able to log in from my laptop!!

On another note, I imported my ground control ini file into webcontrol. I’m taking RPI to Maslow and connecting them together for the first time, hopefully, this will go well.

Thank you!!!

I’ll let you know how that goes shortly :laughing: :sweat_smile:


I should have put Maslow instead of webcontrol in that status line… It does not matter if it is Maslow or webcontrol as long as all of the references and file names are consistent. Glad you got it handled!

1 Like