Maslow Home Maslow Community Garden Newsletter

Ground control will not find .nc files

I was having this problem the other day, I did figure out to go to icon view to find them. Today again I am unable to find any .nc files no mater what I try. I am using one of your test .nc files without luck.

Update turned off antivirus, made no difference

Which test nc files is it? Are they from MakerMade?

Can you post a screenshot of what you are seeing? It might help us figure out what is going on

bar
February 19

Frank:

I am using one of your test .nc files without luck.

Which test nc files is it? Are they from MakerMade?

Can you post a screenshot of what you are seeing? It might help us figure out what is going on

Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

causeB.nc (10.6 KB)

Hmmmmm…It’s showing up for me so it’s not the file:

Are folders showing up for you? Like if you create a folder on the desktop can you see that? Do you have any insights into what made it work that one time?

I have some folders on the desktop and they are not showing up. Yesterday when it started working I switched to icon view. In fact it worked this morning and this afternoon nothing worked. I have deleted it a couple times nothing changes. I can run all the motors manually but unable to get the files to show up

This is very strange, I haven’t heard of this happening before. The fact that folders aren’t showing up indicates to me that it’s not an issue with the file extensions or their names.

Have you tried Web Control?

Will that run the maslow?

Yes, webcontrol replaced the inner workings of ground control (it uses a browser
instead of producing the GUI itself)

David Lang

I went to their web site and I am not sure which one to use. There were several options

what do you want to run it on? (Windows, Mac, Raspberry Pi)

single file is easier to install, but a bit slower (much slower on a Pi)
single directory is messier to manually tweak, but faster.

Windows, I am not super computer savvy so I am not sure what you are talking about .
One more clue, I noticed when trying to open GC it would just flash but not open. I would then have to delete it and reinstall. But GC still would not find the files, this happened a couple times

Let’s try looking here: https://github.com/madgrizzle/WebControl/releases and grabbing either the windows 32 bit or windows 64 bit single file versions of Web Control

I think that is the next logical step to try.

At this time I purchased a new laptop and GC is running. I have also loaded Webcontrol as a backup. I dumped Makercam and started using Jscut.

Thanks for your help

1 Like

Fantastic news! That is great to hear.

Couple questions, everytime I unplug the USB cable I have to recalibrate the machine

How can I home the bit over what I want to cut? Don’t understand why it has to travel so far before starting cut

Couple questions, everytime I unplug the USB cable I have to recalibrate the machine

next time you calibrate, stop just before you hit the button to move to home,
mark the links that are at the 12 o’clock position on the sprockets. That way
the next time you need to reset things, you just need to move the sprockets to
12 o’clock and put the marked links on those pins (it doesn’t need to be the
same pin, any pin will work)

How can I home the bit over what I want to cut? Don¢t understand why it has to travel so far before starting cut

That’s a decision made by the CAM step, it decides what the cut order is.

David Lang

1 Like

Your setting and location should be saved. You need to wait two seconds after the machine stops moving for it to save it’s position. You should hear the motors go quiet when it is saved.

Even if you pull the usb cable out mid cut and the machine does not have time to save it’s position you will not need to re-calibrate. Only the lengths of the chains need to be re-done which can be done by running Actions -> Set Chain Lengths Automatic

Another issue I am having is why do I get the double lines and how do I get rid of one of them?

You should be able to click on one or click and drag to select one of them and then press ‘delete’ to make it go away.

Are you generating these files by tracing the edges of a thicker line?