Maslow Home Maslow Community Garden Newsletter

Help/Introduction

#1

So I’m new to all of this and more than a little excited. Just thought I would throw an introduction out mostly because this ACTUALLY seems like a location where people are involved (I know, crazy). I just got the Maker Made, (I keep hearing and seeing Maslow and I assume that it became Maker Made), but I’m having issue with putting it together. The first (but not the last issue I’m certain) is that the heat sinks were already installed the wrong way. Ok, a little about me. I’m 32 years old, live in Western CO, disabled due to a motorcycle accident 4.5 years ago, got into carving about a year ago but can’t hold my hands steady so I got my first CNC last August for my birthday (inexpensive from China, took me 7 months to get it working), big into learning to do the things I can do still with a traumatic brain injury, and that’s me. Sorry that was so long, I’m just excited to be here.

7 Likes
#2

Welcome Eric! (@Arykk ) Glad to have you in the community.

So, Maker Made produces the kits that are equivalent to that of the original Maslow. Essentially Bar and Hannah decided to move on to other projects after developing the Maslow and shipping out several rounds of kits. Maker Made took up the gauntlet to continue compiling parts for future kit orders. So, what you have is essentially a Maker Made Maslow.

Alright, so, having bought the original Maslow way back when (it seems like) I am not sure what heatsinks you received. A picture would help, though, since you are new it will take a few more posts and liking other’s posts before you are allowed to post pictures (get on the reading train and explore the wonderful world of the Maslow forum!), in the meantime could you explain why you think the heat sinks are installed the wrong way?

What other issues have cropped up?

Don’t let the set backs get you down. It’s all a learning process!

5 Likes
#3

Welcome to the Forum!
Have not much to add, other then some fans over heat sinks could extend the life of the shield, unless you have the AC directly blowing over them, like me :slight_smile:
Greetings from a tiny island that might get it hottest summer in history this year.
Kind regards, Gero (chip-monk)

edit:

Yes, some of us are crazy. Me for sure.

2 Likes
#4

Crazy is O. K! Crazy is as crazy does…

2 Likes
#5

just bumping the post up :wink:

#6

Uploading: EA6C423D-9BD3-4015-AC49-4C8F968369C5.jpeg…

#7

Now that I look at it again I realize it’s fine.

2 Likes
#8


The air-flow could be optimized by turning the sinks 90° but i don’t think that matters.

1 Like
#9

or by moving the fan or rotating the board 90 degrees :wink:

now that you’ve solved that issue, what’s next? :slight_smile:

1 Like
#10

I’m sure I’ll be letting you know.Thanks.

1 Like
#11

I’m concerned that I have hurt the Arduino in some way, I ended up moving it several times trying to find a good location for it. I actually bent some of the prongs from the gSheild, but I may just be worrying too much.

#13

as long as the prongs and/or solder connections are still intact, it should be fine. Just bend them back into place. The boards are pretty robust. I once found an ardupilot (arduino configured to run a small drone) board in the gutter on my street. The pins were all bent up, but all the components seemed fine. An hour’s worth of work straightening everything and I had myself a working ardupilot board!

Now excessive heat and electrical current are a completely different story.

That all being said, are you having problems connecting to the board?

#14

So I’ve come up on the next issue. When I tried to get the firmware loaded and going, I have uploaded the firmware, the updated attachments, and changed the system in the ways that the website tells me. When I try to get it moving It pops up saying, Arduino: 1.8.7 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

cnc_ctrl_v1:36:20: error: Maslow.h: No such file or directory

compilation terminated.

Please let me know what’s next

#15

You are perhaps trying to upload from the un-extraced .zip file.
Unpack to a folder you can find and load it from there.

#16

Sorry, but I’m the type who can follow specific directions, but that’s about it.

2 Likes
#17

The file for the firmware is compressed, ‘zipped’. To upload it it need to be unpacked. If you are on win$, it will display you the content as if it was a regular folder. The little tipper on the icon is hardy visible.
If you click on the file you see an option to ‘Extract’ the file (top bar). Create a folder to place the uncompressed firmware and repeat the uploading with the file from that folder.

Skip the stupid top part of this tutorial below, i guess i was drunk, the detail info with pic is worth a look.
https://drive.google.com/open?id=11Q5WBnmKBH_2bNahkFyXiZNlESf9TjCYlzXOWwsml-Q

1 Like
#18

What he (@gero) said… I was busy writing a post, but he’s covered it. Right click on the folder that you downloaded and hit one of the flavors of “extract”. I believe “Extract to” will allow you to specify a place to unzip the folder’s contents.

2 Likes
#19

I assume you have already downloaded the Arduino IDE

Navigate to the folder that has the zipped file you downloaded (as shown in the video), then right click on the file to bring up the extract context menu.
Once you have unzipped the folder, you should be able to open the file " cnc ctrl v1.ino" in the IDE
then just continue following the directions from step 4 <== That will link you to the instructions you have probably already been following

Let me know if that helps

3 Likes
#20

Thanks Keith. I’m having a hard day today so I’m going inside to lay down for a bit. Thanks.

1 Like
#21

image
Now imagine that on the screen resolutions we run today. Who will see it?
It’s far to small, plus displaying the content without a note is misleading.

1 Like