Maslow Home Maslow Community Garden

Latest firmware Sled not keeping up error


#1

Hi everyone,

Just updated to the lates firmware, can do the calibration cuts, however I get the lovely sled is not keeping up… Is there a recommended ‘stable’ firmware version? The notes here:

github maslow firmware keepingup

Don’t seem to be in the ‘mac’ version of Groundcontrol, well on the settings, I can’t seem to find an advanced settings or the option to change mentioned in the link… I’ll keep playing any suggestions welcome, this is using Z axis, however there’s a reasonable PSU that came with the unit and the PSU is plugged into the daughter board and nice big heatsyncs on the driver chips :wink:

Guy


Corrupted firmware/groundcontrol using different versions weird G2/G3 cuts
#2

Click on settings, then click on the top text that says Maslow Settings. The advanced settings are hidden there.


#3

thks, punched it up to 120! Sled cutting dutifully away. Heat syncs cold, so It’s carrying the load A-ok.

On the next questions, normally on a cnc, I’d be able to ‘play’ e.g. dry run without cutting, is there an easy way or would this be an UI enhancement, e.g. lift cutter, and play run all the moves with the Z axis up…


#4

You can ‘dry run’ a .nc file or move the sled with the arrows and the Z with the Z-menue.
I do dry runs without a bit in the router. That prevents scratches on the sheet. Setting Z0 way above the sheet would also work, but make sure you don’t hit hardware limits damaging your setup.