Maslow Home Maslow Community Garden Newsletter

M2 won't cut entire perimeter of outline. get soft limit error?


IMG_1901
IMG_1902

I’ve been using my machine for awhile now… mostly small parts. just tried cutting a 60" x 25" simple shape and the M2 cuts almost all the way around but stops 3 inched from where it started. I get a soft limit alarm, saying it exceeds travel. What the hell? I then tried it again and move my entire piece up and did it again… same error and stops at the same place? I dont know what to do. I even turned off $20=0. Can anyone help?

Update… I just tried cutting a simple circle… its 3/4 around the circle then just stops with this limit error… So frustrating. any help appreciated.

Update again… So I recalibrated my entire machine … still stops at the exact same spot and can no longer cut anything without this soft limit error popping up… ugh. I have no idea what to do. Things used to work really well…

1 Like

There might be a setting for the maximum dimensions which could be the error, if it’s not obvious it might be worth reaching out to makermade, I know they have a facebook group that’s pretty active and they might have seen this before.

Edit: Ah, I see this was already answered elsewhere by folks smarter than me :grin:

softlimits are still on if it is kicking the softlimit error. It thinks the system is out of bounds, but this error points to something really weird. Typically the softlimit will be for a z axis trying to plunge too deep or lift too high or a cut extending beyond the edge on the top, bottom, or sides. One may speculate a number of reasons why it is doing this right here, but I would refer you to @zaneclaes for further scrutiny because I’ve never seen this before and the system shouldn’t think it is out of bounds for the gap you are pointing to with your finger.

I’m thinking that it is stopping there because that just happens to be to point where the board is being told to go 1/2" deeper in three inches. I notice that the machine will run for a few seconds after you leave Makerverse screen on your computer, but then stop until you open that window again. like its waiting to receive the code to move forward. Hopefully today I can try changing the Z to $132=100. But I wish I didn’t have to.

1 Like

The classic maslow does not have softlimits in the z axis, only in the x and y, but you can’t turn them off. The z axis softlimit was something I argued against, but wasn’t convincing enough to get it removed. Most are cutting 3/4" ply at the thickest, so 25 mm / 1" limit is a reasonable default to not destroy the z axis mechanism. There were reasons it was selected. Your use case is a little beyond the typical use case. The good news is there is a path to modify it without a firmware code fix, reprogram and recalibration, but you do have to restart your cut. You may consider chopping your gcode down to the point where that z axis plunge begins. You will need to make sure you have a G1 command to get it there before it does the z negative plunge to finish that cut. Best of luck to you.

1 Like