Maslow Home Maslow Community Garden Newsletter

Makerverse / Axis is marked inactive and not moving

I have all motors tested and connected properly, Y and Z axis are moving but X-axis is not and marked inactive in the axes settings. This is clearly a software problem and I can’t find any related topic to solve that. Please help!

Update: I didn’t realize earlier that X-Axis checked status is a default setting and cannot be changed. And still, I have Y and Z working normally, but X just doesn’t respond (console shows outgoing command and returns with OK).

Sorry, I haven’t done anything with the Makerverse software. Hopefully someone on here has! Bumping to get it more visibility

Have you looked at the .makerverse file to see if you can find the setting and change it manually?

No, I cannot locate that file. Where should I be looking?

It is normally found as a hidden file in your user home directory. I have mine in the user folder in the raspberry pi. it looks like this:

but I don’t think that is the answer to your problem unfortunately.
@zaneclaes - any idea on how one would declare the x axis inactive or reactivate it?

Yes, unfortunately it doesn’t look like it has anything to do with it… so confusing! I wonder what may be the cause, if no one else is familiar with this problem. I just got the kit and everything should be running by default setting.

mine works and the x axis is disabled as well.

In order for your y axis on the maslow to work when it is jogged, both motors have to move. Do they both move? I wonder if you have to have an x axis no matter what and so we cannot disable it, so it is greyed out and always active.

Yes, both motors are moving and it keeps the line vertical. I don’t think it has anything to do with Makerverse, since I tried to run it with freshly installed CNCjs and got the same result.
It works perfectly fine with Groundcontrol using MEGA board though.
Is it suspicious that I keep getting error messages (“no device found on #port name#”) with Arduino trying to re-upload the firmware. Is it possible that Due board is corrupted?

You can clear the eeprom board memory by typing this command in the terminal window:

$rst=*

Disconnect and reconnect and then recalibrate.

2 Likes

Yess, it worked!! Thank you so much! :slight_smile:

2 Likes

Glad to hear that worked! Thanks for responding.

1 Like

Glad you got it sorted!

1 Like