Maslow running in reverse on new laptop

We’ve been running Ground Control to control the Maslow. It works fine.

Yesterday, I used a new laptop to run Ground Control to control the same Maslow. Everything worked.

Then I dismounted the sled to attach a dust collector adapter. I zip-tied the chains before removing the sled so they wouldn’t jump the sprockets
Today I put it back on and now the Maslow runs in reverse: up is down, left is right.

The old laptop still runs the Maslow correctly, so it doesn’t seem to be a chain issue.

Both laptops show the chain feed as ‘top.’ When I tried to change the chain feed setting to ‘bottom’ on the new laptop, it reverted back to ‘top’.
Tried all USB ports
Deleted and reinstalled latest ground control v1.26
Rebooted laptop and Maslow
Manually copied calibration setting from the old laptop to the new one
Verified we are connecting on Port 3
Sometimes the new laptop runs the Maslow in reverse, but sometimes the motors don’t turn at all, they just whine. They don’t get hot. We verified the sled is not hung up.
We took up tension on the chain to verify the motors are not just overloaded.
Any ideas?

Double check all connections to … YOUR Z AXIS MOTOR, and the other 2! then get the glue gun !