Maslow Home Maslow Community Garden Newsletter

Maslow Z Axis issue

When cutting a shape my z axis retracts back to safe heat then plunges down to next depth. It does this on every path. Iam very new withe the Maslow.

What are you using to generate the gcode? That seems like something that is related to the gcode and not the Maslow controller.

correct depends on the software used to make the gcode. Makercam inserts in wayyy too many up/down z axis commands. You can also use a gcode optimizer to speed up the work flow or use a faster z axis motor

I have an open source project - GCodeClean which does some cleaning up of the GCode.

However you can find the relevant codes yourself in the GCode file, and edit it with your favorite text editor (I recommend VS Code though).

Look for lines with Z which have a positive number (which means raise above the surface), followed immediately by lines with a Z that are negative (meaning lower below the surface - cutting).

If the X and Y don’t change, or they aren’t even present in the lines with the Z codes, you can then delete that first Z code, and just leave everything else.

Iam using the programs that came with the Maslow. Iam drawing in Inkscape. At first when I was running the preloaded projects it was fine. Now iam trying to get used to the layers and tabs. I was just curious if it was something I changed.

Makercam is also Flash that is going to fade, most browsers block it already by default because of security issues. Sooner or later you will want a CAD program if you are not only making art and signboards. One other option for Inkscape .svg is FreeCAD. I made a video (no sound) here FreeCAD0.18.4 SVG to CNC
I’m not sure but think that Fusion360 can also import .svg