Maslow Home Maslow Community Garden Newsletter

No cutting straight

Hey all!

I need some help getting up and going with my first machine. Here is a link to my documented build.

The steps taken so far

  1. Built the standard maslow size, I chose not to use the elastics to tension the Chains. Instead used hanging weights.

  2. Bolted the rougher to the sled with NO Z motor.

  3. Went thought the calibration, and everything went well. The cuts seemed straight, and nothing seemed odd to me.

  4. Ran a test cut from the ground control software, manually did the plunge with the rougher. Test cut was fine and seemed to work.

  5. Removed the sled and added the auto z and replaced the sled.

  6. Designed a part in Solidworks, imported it into fusion 360 and generated tool paths. I am familiar with fusion 360 because we do the same process at work when we make parts.



  7. Setup the Z axis and took a cut.

  8. Cut is not straight, and does not match the indented shape at all.

Here is the code loaded into ground control.
scannerv3.nc (1.5 KB)

The second issue I have is the rougher holder came loose while cutting. I think I was afraid of over tightening the rougher bracket. I didn’t want to crush the rougher and wear it out faster.

Where do I go from here?
Try to do a re-calibration and tighten the clamp on the rougher?

Any help would be greatly appreciated!!

1 Like

When you changed the weight of the sled (by adding the z-axis) you affected the calibration, but to be honest, I wouldn’t have expected that much of a change. Nevertheless, that’s likely the culprit.

Thank you for responding!

I measured the weight of the sled before and after the upgrade. Here is what I came up with

Original Sled with metal parts, bricks, and rougher holder was 13.8 lbs
Original sled with metal parts, bricks, rougher holder, and rougher was 17.4 lbs

The sled alone with metal parts and no bricks was 5.16 lbs.
The Z axis parts and hardware weighed 4.3 lbs

I added 5.16+4.30 lbs. This gave me 9.46 lbs after the upgrade.
Then I subtracted the original (13.8)-current (9.46) to give me the weight i needed to add. Which was 4.34 lbs.
I found a brick in the yard that weighed 4.7lbs. I cut that in half and added it to the sled.

The weight with Z axis upgrade and the 1 brick is 14.1 lbs.

Would the .36 lbs make that much of a difference? So doing a re calibration would fix that issue?

Definitely recalibrate. I would question the original calibration or perhaps you jumped a chain tooth somewhere in there. At a minimum, reset your chains.

2 Likes

No, that would be shocking if so. I’m now thinking as @orob suggested that the chains are not where the controller think they are. Before recalibrating, try resetting the chains. If you marked the chain link that was on the top tooth of the sprocket during the calibration process, it will be fairly quick to do:

Thank you for sharing that article! I would still have to do a calibration first then I could mark the chains and If I needed to reset the chains in the future I could do this?

D

You might get by without redoing the calibration because of the effort you put in to equalize the weight, but I would still recommend doing it and marking the chains in the process so you can reset them in the future, if needed.

This evening I tried to do a re-calibration I got to the step 11B (wiki: how to get calibrated) in the calibration and something seems off. The left chain stops extending at about the middle of the machine 4X8 plywood. Where as the right chain seems to stop extending 1ft from the floor? When I did this before the chains were hanging equal length. Is this right? I have done this step 3 times and same results every time.

I hit the move to center button. The chains are still different lengths from the center of the motor to the end of the chain. The left is 64in and the right is 69 in.

What do you see when you run Actions -> Test Motors / Encoders? Maybe one of the encoder signals is not making it back to the controller board?

I ran the motor test, everything seems to pass. This is a screen shot of ground control.

OK, that is good news. At least we are probably not looking at a hardware issue.

My guess about what is going on is that some calibration value is way off and is causing something to work incorrectly. Under Actions -> Advanced there are buttons to wipe the EEPROM (which are the calibration values stored on the machine) and to restore the default settings:

You could backup your settings before doing that, but given how far off they are now it’s probably not worth it.

Starting from a clean slate I think is the next thing to try.

Thanks for that recommendation! That seemed to help with the chain issue. Both chains now end in the same spot and I was able to move onto the next step.

This created another issue. Cutting the Calibration cut. Cut number 1 went really well. As the sled traversed to cut number 2 the z axis kept going up and up and up until it hit the limit of the C-Beam. I stopped the cut because I was afraid I was going to damage the C-beam.

Fantastic progress!! Nice work.

OK. On to the zaxis. I think the issue there is the failure in the zaxis motor in the test. Often times this is just caused by a loose cable. Can you unplug and replug the zaxis cable on both ends and try running the test again?

1 Like

It works! Booya!

Solution: The first issue was the software I’m guessing. Restoring defaults and wiping the eprom seemed to fix the chain length issue. The second issue was with loose cables on the motors. The motor test proved them out. Did a cut last night from fusion 360 (the same one shown above) it worked beautifully!

Thank you everyone for the help!

3 Likes