Maslow Home Maslow Community Garden Newsletter

Not displaying shapes in graphic area

I’m running WebControl in simulation mode, Fake Servo is on. I loaded a couple of files from the community garden. I can open and run SixHookCoatHanger.nc, and it displays in the viewing area as it cuts. It says it was exported in FreeCad.
I cleared the code, opened Folding Chair.nc which it says (Generated by PartKam Version 0.05), nothing is displayed. I can run it, the sled moves and does things, but no display.
Same with Sled with alignment spacer.nc. I uploaded to an online gcode viewer and it displays there.
Do I not have something set correctly? Same display on laptop and phone.

Can you send me the gcode at madgrizzlemaslow at gmail dot com? There’s something in the file that’s causing the display to stop working (I’ve had it happen before recently). You can try to downgrade in the meantime to an earlier version. Also, you need to enable the zaxis in settings (I assume you have a zaxis)… it’s currently asking you to manually change the z axis height

Actually, try editing the file and delete the M3 line (turns spindle on if you have spindle control). If that solves it, I know the issue to fix.

Does Fake Servo emulate z-axis?
I just went from 0.929 to 0.927 and I can see the sled now.
Edit:OK, enabled z axis, thought I had done that and it hadn’t worked, but it does now in emulation.

Ok… I think I know the problem and will look into it.

went back to 0.929, loaded sled to make sure still invisible, which it was. I made a copy and deleted the m3 line, loaded that one, and it was visible.

thanks. I’m building a release that will fix that. It will be up in a 10-15 minutes.

1 Like

In 0.930 the following file runs and displays on my laptop, but on my phone, only ever shows the round processing symbol. It shows on my phone fine in 0,927. Unless it’s my phone, but I’ve reloaded 0.927 and 0.930 twice and it seems consistently doing the same thing.

https://github.com/MaslowCommunityGarden/MCM-End-Table/raw/master/MCM%20Table%20GCode.nc
:
In 0.930

In 0.927

Thanks… I’ll look into it. Shouldn’t be a hard fix.