Oval Shaped circles Please help

I know there are a few posts about this but I was unable to find a solution in any of those so i thought I would such out those of you much smarter then me.

I decided the other night to finally cut out my final sled as the temporary one I am using isn’t very good. So I loaded the files and followed the instructions and set the cutter off on its journey. First issue is how slow it drills holes. I mean does it really need 8 passes to drill a hole? That seems like too much. anyway so I left it cutting and came back as it was cutting the final circle and noticed it was off by nearly 2 inches from top to bottom and side to side. so rather then a circle i am getting something more like an egg or and oval. I understand this machine is not designed to be perfect but 2 inches is a whole lot of inaccuracy. At this point I have performed the full calibration about 3 times. so as far as I know it is perfectly calibrated. I followed the tips I found in the other posts but nothing seems to have fixed it. I received this machine a few weeks ago and I am running the most current firmware that I know of. so why are my cuts this far off? I was experiencing chain skip from there not being enough tension on the chains but I fixed that with the bungee solution and some WD40 so as far as I know I did not get any chain skipping and the cuts look normal other then being 2 inches off.

Can someone explain what may be my issue and please pretend I am a noob dummy because I am and this is my first machine of this kind. I’d really like to start making stuff with this thing rather then blowing through all my materials and getting really poor output.

Thanks very much in advance.

P.S I am using the ring kit, Z axis and bolt frame. my chains come from bottom rather then top if that means anything.

Also If I was going to invest any time in leaning a software that will give me the best experience with the most features what should it be? Makercam is very limited and glitchy and Easel isn’t much better I prefer a software solution that isn’t web based. thanks for your help.

Not sure what the problem is, but it shouldn’t have happened. We got to this stage and our sled was precisely the right size in x and 1/64" short in y.

One thing you could do is examine the G-code. This is a worthwhile exercise regardless of anything else. You could load it up at ncviewer.com and watch the virtual cutter respond to your G-code.

Cutting holes might take 8 passes if they are pockets. Here the tool is cutting a circular shape bigger than the diameter of the bit. In ncviewer you will see the tool moving around the hole 8 times and you can work backwards to the element in the original drawing and the CAM settings that led to that specific behaviour.

Next you can check the x and y coordinates of the left, right, top, and bottom extremes of the outer circle. Check that the difference in coordinates is what you expect, e.g. from left x to right x should be 18" plus the diameter of the cutting bit.

If your G-code file is faithfully describing the result you want then the machine is not cutting it as requested. If your G-code is 2" off then the machine is cutting what you asked for, but not what you wanted. This will tell you where to look for the problem.

Once you grok G-code it’s quite nice to be able to simulate it and see that the tool is moving exactly as you expect. This means you’ll have no surprises when you run it on the machine.

Clearly you have serious issues to resolve, as a 2” error is pretty extreme. I am not sure how helpful the following topic will be for you, but it is full of helpful tips that did help me got to round circles…

One action that really helped me was to follow @Jayster’s experience and manually construct the sled… his process insures that the router spindle is very close to centered, which is critical to accuracy and precision…

And a real understanding of accuracy and precision with the Maslow was also important to me… I highly recommend careful study of the following…

Spend some serious time with this article… I promise you it will be most helpful.

Best of luck! With the Maslow, persistence pays!


Thank you for the reply, I did as you instructed and imported the sled file into NCviewer and it appears to be correct as far as I can tell so I would assume its a calibration issue. I think it may be a conversion issue as I have been converting inches into meters which I am told can be very problematic. since I live in the states I don’t have a lot of experience with the metric system so I went out and got a laser measuring device that does meters. So I will repeat the calibration process using that and see if it makes a difference.

Anything in particular I should be paying special attention to in the calibration process that might be causing the issue. Could it be that my router isn’t perfectly centered on the temporary sled? or maybe a measurement I really botched setting it up. I also would note that my top beam is not exactly 10ft its longer by maybe 2 inches or more.

anyway thanks for the tip with ncviewer.com, that site is badass.

This is probably me reading into things too much, but you do me milimeters not meters, right? You should be getting a number around 3000 for the distance between the motors :smiley:

Yes your correct not sure why I was getting mm but yes meter, I got around 3076 I believe

1 Like

Cool. Well that certainly points the finger.

Glad you found ncviewer useful. G-code is pretty simple, so when you can see what it’s doing you should either have no surprises, or you can easily answer “why is it doing that?”

The only problem I had with calibration was keeping a light tension on the free end of the chain so that it didn’t skip a tooth. I don’t think it would be badly wrong if I hadn’t noticed, but I had to do a couple of the steps twice because the chain fell off.

Now that it’s done I am getting better than mm accuracy, and the last thing I cut, which was an approximately 8 x 10" rectangle, had perfectly square corners. Frankly I’m quite impressed.

So here is an update, when I received my Maslow I didn’t have all the right tools to make the temp sled perfectly, since then I have purchased many of the tools and so I decided to go ahead and remake the sled. This time I countersunk the bolts holding the bricks and made sure the circle was dead center though I think ether I am crazy or the instructions are wrong. The temp sled instructions tell you to make a 1.5 x 1.5 inch circle but its in fact a 2.5 inch circle if the point is to have the same size hole as the router mounting plate as shown in the images. Anyway I did that and made sure the sled was 18x18 as instructed and made sure everything was centered perfectly. I have a feeling the bolts sticking out and the router not being exactly centered may be causing some issues, though I’m not sure that is causing my oval issues.

Tomorrow I will redo the calibration with the more precise Laser measuring tape I purchased today.

I have also dumped the Arduino and reloaded the firmware and uninstalled and reinstalled groundcontrol and powered off and on the Arduino.

I also installed a shop vac to suck up all the sawdust.

I will report back tomorrow when I have time to do the calibration. Thank god for three week Christmas break.

Thank you to everyone who had responded so far hopefully the more precise measurements and redoing the calibration will solve my oval issues.

1 Like

Also has anyone tried to disable the Z axis and leave the router off and installed a pencil or pen or something to draw on the material to see what its doing? I thought this could be a good way to see what the router is doing without wasting all your materials. wood isn’t super expensive but it adds up if your doing a bunch of bad cuts.

1 Like

Use the search, Luke:

The hole in the centre of the sled on has to be big enough for the bit to go through. Maybe the collet and some other protuberances around it need some clearance too, but I don’t think it has to match the router precisely.

Second update and I feel this may be where I am getting my error. I went through the maslow calibration without the machine connected and noticed one thing I have never done !

there is a hint which reads:

"Hint - Update the distance value to move the chain a short distance to remove most but not all the slack.

Wellllll I never did that when I did my Calibration and if I remember correctly there was likely about 2 INCHES maybe a little less of slack which if I am correct is likely what is causing my machine to cut ovals and not circles!

Please pass the dunce hat! I will now sit in the corner and think about what I have done.

Before I get too excited, I will redo the calibration with this hint in mind and see what I get. Would someone verify that this could and may in fact be my issue?

Also could someone please explain the test cut portion I am so confused as to how I should measure, I assume I am doing it wrong because if I read it as I understand it I could not possibly get a accurate measurement as I don’t have a 8ft arm span and couldn’t possibly measure accurately from one end to the other without the help of someone else. since there is no mention of a buddy to help you, I suspect I am measuring the wrong thing. So could someone please treat me like an infant and explain in layman’s terms how I should be measuring?

Thanks everyone for indulging my noobishness.

Edit: did some quick math and turns out I am on the right path @bar asked me what my chain length was and said it should be around 3000 mine was close but off by about 76 or 67 (cant remember which one) mm when converting that into inches it’s, you guessed it, about 2 inches off of what the machine expects. if that is the case then I simply need to repeat the calibration with my new information and I should be good to go.

1 Like


He did it by himself. A metal tape measure will lie flat against the surface so that you can get a measurement. Ignore the first example in the video which is very small. He re-does it with new firmware and makes cuts over a larger area.

The measurement is described in the calibration procedure, i.e. which edges of each cut to measure to.

Sounds like you’re onto it. How exciting!

1 Like

Yes I have watched that video, I guess I’ll watch it again.

Yes I’m a problem solver at heart so I like to get into things like this. I’m out and about right now but when I’m done I’ll go home and do the calibration and see what I end up with.

1 Like

Okay so I am home now and I have re-watched this video and it would appear my cuts were wayyyyyy off as his are only about 9 inches or so apart and mine where wayyyy further apart, maybe I’m missing something but the test cuts I made where closer to 5 or 6 feet apart maybe more. Is that normal? did I do something wrong or are the test cuts different now in the new groundcontrol? if my test patter was that close apart id have no issues measuring them myself but they are way further. He did mention that the measurements are taken in a different way in the new version, is this what he is talking about? in which case how does one do the new measurements without help on the new version?

Edit: Never mind I see that he repeated that step later in the video and my cuts look similar but he really fast forewords through the measuring process which is what I am confused about. I took a screenshot of his number to see how close mine are to his.

1 Like

I had a similar problem. My solution was to make the connection between the top motor mounts more rigid. When the router is near the top of the material, there is a lot of tension and the motors were being pulled closer together. This resulted in the router not going a high as it should have. In my case I was using the original frame design and had to put two 2x4s across the top of the unit.

I think I may do that as well because I see a small flex when the motors pull against each other however I don’t think it should be causing a 2 inch difference I could see that helping in things that must be really accurate though so its definitely something to consider. I am using the new bolt frame design so i have a 10ish foot 2x4 spanning the top.

@bar @ame @Dustcloud Final Update!!!

Followed the my own advice and the advice of the calibration, measured twice and made sure I was reading everything twice and the result was an extremely accurate circle and no more oval!!!

Can’t tell you all how thankful I am for this forum and how happy I am with my results thus far. Now I can finally feed this beast some wood and put it to work.

Thanks to everyone for linking other threads and helping me work through this! You guys rock!!!



Nicely done! Please show us what you are making.

Well I have a few things in the works, the first will be, and the reason I purchased the Maslow is I build custom arcade systems for clients. Normally I’d have just cut everything by hand but my most recent client wants something that doesn’t exist yet which meant creating it from scratch. Because I wanted the system to look professional I decided to go the CNC route.

The second is for work, professionally I work in the film industry as a lighting and camera support. I have a company and I’d like to build some Apple boxes (a tool of my trade) with my company logo on them.

Another thing I had in mind was a series of art projects. Things that reminded me of 80s and 90s pop culture which is an era I’m particularly fond of.

As soon as I get some pictures I’ll be sure to post them up in the community garden.

1 Like

I am having same problem so after reading all this after the cain tightens up it then releases it, it then gives measurement, then i measure it wih tape measure and its different. so do i then change the measurements to what the tape measure reads?