Maslow Home Maslow Community Garden Newsletter

Problem connecting/updating the firmware

I just updated to M2 and went straight to CNCjs to calibrate. I chose the port from the list and console screen has showed up. However, it didn’t run any initialization like it supposed it. None of the program functions worked either.
I figured firmware needed some tweaking and went to arduino. Installed the DUE boards, set up the port, opened MaslowDue and tried uploading, like I previously did with MEGA boards.
Pressed Upload and got the “Device not found” message. With some fiddling around (pulling out the usb cord, restarting arduino and even computer) finally I managed to run the upload process. It seemed incomplete (instructional video on YouTube has shown more component/progress bars running at the console) and didn’t help getting it to work in CNCjs. Another attempt to rewrite the firmware ended up with another “device not found” message, and later connected and uploaded again with no obvious reason.
I ran out of options and can’t find the solution to make it work. I would appreciate any suggestion or advise.
Thank you!

Look up arduino basics in the wiki area of the forum. You need to get the due board set up in the arduino environment to be able to reprogram it. Also, you might consider using makerverse, the updated version of cncjs for maslow.