Re-calibrating after setting "New Home"

Maybe I’m missing something but the calibration steps, including the test cuts, took me an hour or two. After setting “New Home,” I’m unable to return the sled to the old home (center) position. Looking through the forum I’m coming across people recommending to re-calibrate the sled.

Am I understanding this correctly that after every cut you must re-calibrate? Including wasting a sheet of plywood doing the test cuts?

At worst, you should only have to manually calibrate chain lengths. This will just do the final feeding out of the chain to the center of the workspace. You should not have to go through the calibration steps unless you want to improve accuracy or have made changes to some physical aspect (new sled, for instance).

This is exactly why we need to replace the current GC implemented ‘new home’
with firmware implemented G54 and friends.

Fixing the GC implemented ‘new home’ to work right and handle the appropriate
conditions is going to be more work thatn implementing G54 and still be maslow
specific

David Lang
kk

Are you having trouble getting the sled back to the coordinates X:0 Y:0, or is it that when you return the sled to X:0 Y:0 it isn’t lined up with the center of the work area?

1 Like

Yes, for example, I went through the calibration steps again, the exact same steps I used originally which worked. This time when I get to the step to measure the chain by pulling it tight with the motor, I cannot get it to return to center. The steps are really vague anyway and there seems to be two ways to do it, one with the sled attached, and without the sled attached. The steps indicate that the motors will return to center, but there’s enough slack that my sled is on the ground.

There’s no way to retract the chains because when you click go to center, it retracts a few inches (not near enough) and the only other commands are to extend. I can’t figure it out.

I’m not sure I fully understand, but I believe that the issue here is an unclear step in calibration process.

Absolutely not. You ONLY need to do the calibration process when you build or modify the machine. @MartinJ is right that all you should need to do is to do Actions -> Set Chain Lengths Automatic

If that doesn’t solve the issue, then we will investigate more

Thanks!!! I’m going to give it a try and report back.

1 Like

So I followed your steps and clicked Actions > Set Chain Lengths and this took me back into the calibration process.

The calibration step it navigated me to was the step to set the sprocket is pointing up. After completing that step, the next step is the Adjust Chain Lengths step. This is same step that only allows me to “Return to center” which drops the sled to the floor, or extend the chain lengths. This time I was unable to stop the motor from extending so I had to turn off power. There was only an inch or two left of the chain before it would have used up all the chain.

In summary, I don’t have a Set Chain Lengths Automatic capability. It just throws me into the Set Chain Lengths manually step of the calibration process.

Adding: after I extend the left chain to the right sprocket and then “measure,” the left chain is near fully extended. From this point there’s no way to retract the chain because both options cause the motors to extend.

Got it, so that means that the machine’s understanding of it’s geometry is off. Basically it probably thinks it is way bigger than it is which is why it just keeps extending the chains.

Here’s what we can do to test that.

First let’s just check all the hardware to make sure things are OK by clicking Actions -> Test Motors/Encoders. Remove the chains before doing this step.

Now let’s take a look at the settings and see if we can figure out which one is off. There are three settings which could be the issue. Will you click settings at the top and then check what the values of these there settings are?

If you just want to force the machine to have reasonable settings. You can delete you settings file and restore everything to the defaults by clicking Actions -> Advanced -> Reset Settings to Defaults.

My Advanced Settings was not clickable so I downloaded all new software and went through the calibration steps. I got to the step where you measure the chain, then enter the measurement of the tip of chain to the router center, then I put the end of chain on the sprocket and click extend (left) chain. There was a countdown and then the chain retracted (went the opposite direction). I went through these steps three times, each time entering the same parameters and measuring the (left) chain, yet the motor goes the wrong direction when I extend the left chain to hook up my sled. Now the motor knows the correct direction when I click extend the (left) chain to do the measuring step, but then goes the wrong direction when I click extend the chain. The right chain does extend the chain correctly.

Triple check the “Chain over, under sprocket” Settings make sure they are correct

1 Like

From my experience calibrating my machine this weekend, place the chain as the picture shows on the extend to measure step regardless of if you are bottom chain mounting your sled. After that step you’ll reposition the chain in the final configuration. This threw me for a loop. Don’t know if this helps - just thought I’d throw it out there.

3 Likes

Am I understanding right that the original question was how to get the original “center of work piece home” back after you designated a home somewhere else on the work area? If so I’d like to know this too.

There is a button “Return to Center” on the Actions page. Poke that, and the sled will move to 0,0. Once it’s there, set “Home” and you’re all set :+1:t2:.

3 Likes