Setting up machine for the first time

I’m having issues setting up my Maslow.

First of all the specs:

  • MakerMade kit bought in May
  • Running Mega
  • Using an Rpi for WebControl version 0.933
  • I uploaded the Holey Firmware from Webcontrol.
  • Top Beam is 3700mm and is 500mm from the sheet (these are just quick estimates, I put the actual in the appropriate boxes in the setup).

I can connect to WebControl, the issues I’m having are as follows:

  • Intermittent motor connection, sometimes when I hit test motors/encoders they work, sometimes not.
  • If I try and follow the steps for setting a tooth to the top, at most I’ll be able to get one movement from the motors, but mostly nothing.
  • Update in Help won’t work.
  • Message: Unable to find valid machine position for chain lengths 160.37, 29.07 Left Chain Length Greater than System Settings Chain Length LeftChainLength: 3724.10 System Chain Length: 3360


Otherwise, here’s a portion of the log:
4.87: B05
4.89: Firmware Version 51.27
4.89: Ground Control Version 1.27
4.90: ok
4.90: Sent: G20
4.91: G20
4.92: ok
4.98: Sent: $$
5.02: $0=2450.00 (machine width, mm)
5.04: $1=1250.00000000 (machine height, mm)
5.05: $2=3722.60009765 (motor distance, mm)
5.07: $3=480.00000000 (motor height, mm)
5.08: $4=310.00000000 (sled width, mm)
5.09: $5=139.00000000 (sled height, mm)
5.11: $6=79.00000000 (sled cg, mm)
5.13: $7=2 (Kinematics Type 1=Quadrilateral, 2=Triangular)
5.14: $8=138.40000915 (rotation radius, mm)
5.16: $9=2000 (axis idle before detach, ms)
5.17: $10=3360 (full length of chain, mm)
5.19: $11=2000 (calibration chain length, mm)
5.20: $12=8113.72998046 (main steps per revolution)
5.22: $13=63.50000000 (distance / rotation, mm)
5.23: $15=800 (max feed, mm/min)
5.25: $16=1 (Auto Z Axis, 1 = Yes)
5.26: $17=0 (auto spindle enable 1=servo, 2=relay_h, 3=relay_l)
5.28: $18=12.60000038 (max z axis RPM)
5.29: $19=3.17000007 (z axis distance / rotation)
5.31: $20=7560.00000000 (z axis steps per revolution)
5.32: $21=1300.00000000 (main Kp Pos)
5.34: $22=0.00000000 (main Ki Pos)
5.35: $23=34.00000000 (main Kd Pos)
5.37: $24=1.00000000 (main Pos proportional weight)
5.38: $25=5.00000000 (main Kp Velocity)
5.40: $26=0.00000000 (main Ki Velocity)
5.41: $27=0.27999999 (main Kd Velocity)
5.43: $28=1.00000000 (main Velocity proportional weight)
5.44: $29=1300.00012207 (z axis Kp Pos)
5.46: $30=0.00000000 (z axis Ki Pos)
5.47: $31=34.00000000 (z axis Kd Pos)
5.48: $32=1.00000000 (z axis Pos proportional weight)
5.50: $33=5.00000000 (z axis Kp Velocity)
5.51: $34=0.00000000 (z axis Ki Velocity)
5.53: $35=0.27999999 (z axis Kd Velocity)
5.54: $36=1.00000000 (z axis Velocity proportional weight)
5.56: $37=33.00000000 (chain sag correction value)
5.57: $38=1 (chain over sprocket)
5.58: $39=3 (PWM frequency value 1=39,000Hz, 2=4,100Hz, 3=490Hz)
5.60: $40=0.00000000 (chain tolerance, left chain, mm)
5.61: $41=0.00000000 (chain tolerance, right chain, mm)
5.63: $42=2.00000000 (position error alarm limit, mm)
5.64: $43=0.00000000 (reserved1, deg)
5.66: $44=0.00000000 (reserved2, mm)
5.69: $45=0.00000517 (chain stretch factor, m/m/N)
5.71: $46=97.90000152 (Sled Weight, N)
5.73: ok
5.73: Sent: $45=0.00000516850
5.87: Message: Unable to find valid machine position for chain lengths 160.36, 29.05 Left Chain Length Greater than System Settings Chain Length LeftChainLength: 3725.15 System Chain Length: 3360
5.88: ok

Of course I put this up and then it magically starts working

1 Like

It sounds like you needed to use the reset chain option:

Glad it is working. For future reference, if the system doesn’t know its location, you unplug and replug all connections (for the pass/fail issue), put the sprockets at 12:00, put the chains on at your marks made when you calibrated, then use that reset menu button and you should be good to go. (intermittent behavior is most often from intermittent connections)

Perhaps if you have a 12’ beam and the system stops when your sled goes to the lower left or right corners, then your chain length might be too short (setting mentioned above) and the system will prevent over extension and only move when it is shortening the chain rather than lengthening it beyond its programmed boundary. This seems logical to me, but I have not checked the code and I have not actually experienced this, so perhaps you could test the boundary and verify this is the cause of the erratic behavior you were seeing?

That’s 90% of what we’re here for :grin: