Sled svg file incompatible with Inkscape

I’m unable to get the sled to display/render in inkscape’s, or anything else that can print. It’s the only one of the design svg files that has this problem. Everything’s there, nicely done with circles instead of line segments, but a couple versions of Inkscape just don’t like it.

I wanted to make a quick copy of the permanent sled by printing the design, gluing it to some scrap plywood, and making it with conventional hand and power tools before doing a full recalibration. It’s probably something simple with the file but I’ve spent several unsuccessful hours. Any ideas, or is the file available in another format?

Would a .png work? I opened the file in Inkscape and exported as .png… Note, it’s 17+ x 17+ ;

Here it is as a .pdf, sectioned to print on letter-sized paper (6 sheets). (468.7 KB)

1 Like

Thanks, that looks perfect!

So it was swamp rats, only fails in Mooselake? Or was it an invisible svg file for you, too?

Medic shift tomorrow, so it’ll be a day or two until I can print it. Appreciate the help

1 Like

Inkscape takes a very long time to come up, but once up, the file opened correctly and quickly. Are there some Inkscape settings I could look up for you?

Mine opens quickly, both 0.91 and 0.92, but never displays, i5-6500 onboard graphics. Will try another computer and see if that helps.

I’m not sure if this is the issue, but I ran into something similar when using a 3d service’s template. The solution for me was to change the View->Display Mode in Inkscape.

1 Like

@Darryl, no different with toggle, no filters, or outline. I’m just about to try and print @blurfl 's PDF. I’m going to make it as designed, but am leaning towards converting into the pantograph version and hoping for a pleasant afternoon in the packed to the gills farm shop as it awaits all the woodworking tools moving to the other side of the wall.


@blurfl - that’s great, and the alignment grid was a really big help getting it lined up. I was doing cut and paste back when it involved scissors, real paste, and that white tape. While the alignment’s not 100% perfect this was way easier than the old days. Think the 3D printer glue stick will work to attach it.



Glad to hear it. I’m a big fan of BigPrint from, a program well worth adding to one’s toolkit.

1 Like

I like your hold-down weights :wink:

Does anyone know what causes the SVG not rendering in inkscape?
I try to gain more insight in Ink-issues.

I just tried to open sled.svg and firefox also isn’t able to display the graphic

Inkscape exits with: Failed to load the requested file Sled.svg (the one currently on gitgub)
Firefox does not render the file. And displays the plain xml as text

Super useful software. When I lost access to a plotter I picked this up and have never looked back.

1 Like

I’m able to view the sled file in Chrome (and Firefox and whatever Windows browser is called now) but I can’t open it in InkScape either. I don’t get any errors, however, just a document with a selectable, but not viewable object. I downloaded the entire Mechanics-master as a zip file.

It does open in Illustrator, however. The only weird thing I see (in Illustrator) is that the stroke is set to “0”. You can view it in Outline mode.

Try this SVG file… I saved this out of Illustrator. See if you can open it in InkScape; I can.

EDIT: Hmmm… that link doesn’t seem to be working. Let’s try this:


EDIT2: Well that’s just weird (the way it displays) but I think you should be able to download it.

For some reason i’m unable to download your file.

I would be good if all the Github files could be opened in Open software by default.
This is a bit of a pain…

I’m not in a hurry for this file, just putting inkscape to the test whenever i see someone struggle with it.

The svg’s in github are generated with onshape right?

So my first guess is that onshape never tested if any of their output’s work in inkscape.

Can you right-click on the big black circle and then “Save link as…” (or whatever your browser’s equivalent is)

I’m pretty sure the SVG’s were output from InkScape. (At least I think so… Bar is an Inkscape user)

If you can manage to get it downloaded and verify it works in Inkscape I’ll add it to the GitHub repository and submit a pull request.


OK, I managed to open it

I had to change the infill color of the big sled circle, then the mount holes became visible

One of the chain mount hole countersinks seems to be missing (the most upper left one)

Also Inkscape sees the file default setting as px. So the actual dimensions seem to be off when I change this to mm This seems to have 373 mm diameter. Or is that correct? I have 320 mm in my mind as being the diameter, not sure where i picked that up. :slight_smile:

In Inkscape, can you change your view selection to “outline” and see if that recess is there, but colored wrong?

I don’t actually know what the sled size is supposed to be.

I’ll give that a try when i get home (i’m about to pack) and can’t find how to “view selection to outline” right now.

Thanks @TheRiflesSpiral

The size could be correct, I probably had 12 inch vinyl records in mind (thats about 320mm).
I soon will get an ‘out of memory error’ from my brain… :smile:

1 Like

I can’t recall the menu item but the keyboard command is Ctrl+5. Keep pressing it until all the lines are hairline thickness and there’s no fill.

1 Like

When I downloaded the black svg, in inkscape there was no stoke set but fill. Selected all and set no fill and stoke to black.