Maslow Home Maslow Community Garden Newsletter

Tool paths from MakerCam not showing up in Ground Control

#1

The very first g-code I created with MakerCam went great.
I was able to open in Ground Control (Windows portable v1.26) and cut the desired test shape. Very enthused at this point!
From what I learned I decided to make a couple small adjustments, such as depth per pass and tab placement. When I opened the new g-code, the tool paths were not there, other than a line to the start point. I restarted Win7- same results. Started from scratch with a fresh file- same results. Cleared my temp files- same results. Deleted Ground Control and reinstalled- same results. Used MakerCam on my Win10 PC with Chrome- same results.
I’m still able to open the first file I made, see and run it, but any file subsequently will not open properly.
I tried jscut and was able to generate and see the tool path in Ground Control, but that software is confusing compared to MakerCam and I’m certain I missed something.
Is there a solution to this? Please help!

#2

It’s a long shot, but a little while ago makercam was rumored to be going out (discontinued). Do you think this could be it?

#3

I think they’re saying Flash is being phased out.
It worked one minute then not the next.
I’d be happy to use something more secure though.
Jscut isn’t flash but it clearly says “Insecure” next to the website address.
I’ve been through the whole list in the wiki:


and none of them are as clean and simple as MakerCam

1 Like
#4

In GC was there a line from “sled” to somewhere off screen?? Mine will do this occasionally and I will need to tell it where home is again. Then it brings the code back into relationship with that home point.

#5

In the final step when you are saving the gcode to a file it will only export “selected tool paths” so you need to click the “select all” button…that’s the best thing I can think of.

I’m working on a new CAD/CAM program right now so hang in there…better software options are coming!

3 Likes
#6

Thanks for the tips! I don’t see a “select all” anywhere, but I drag a box around everything so it is highlighted and when I go to “export g-code” the profile is highlighted in blue.

#7

Can you upload the .svg and the g-code?

#8

CC-GateShapePray CCpray.nc (134 Bytes)
Hope I did this correctly…

1 Like
#9

The g-code is empty, sort of, just going to X-16.5365 Y-11.9326 and moving z to 0.5
Let me check the .svg

Works for me with your .svg, i did

#10

Did you calculate the paths before trying to export them?

#11

Yes I did.
In order to add tabs I need to calculate all first.
I just went through it again to be sure. Same results.

#12

Odd, it worked for me also.

What happens when you open the Toolpaths dropdown menu?

#13

Post a screenshot of the values you add for the tabs

#14

Did you also try it without the tabs? Just wondering if the tabs are the issue. I don’t use MakerCAM, so @Gero is likely going to be more help here

#15

I don’t use makercam either… just playing with it if someone is stuck

#16

we are the blind leading the near sighted

1 Like
#17

If you all are not using MakerCam, what are you using? Like I stated, I’d be happy to use something else if it works better!

#18

I’ve added plenty of tabs and it also worked. I guess your doing something in the tabs that results in the empty file. I’m using FreeCAD, is a bit of a learning curve :sweat_smile:

#19

I use Autodesk Inventor for my CAD/CAM. If I am using an SVG that I didn’t create, then I usually use JSCut, though it is a really simplistic interface, so doesn’t offer a lot of manipulation, and no CAD

#20

The first g-code I made had tabs at 18" which gave me 5 tabs.
I did the same thing the rest of the times.
I just tried it again at 10". Same results- no tool paths.
Will spend some quality time with jscut and see if I can get that to work.
The first go round wouldn’t let me make tabs and the same svg project was reduced in size so I’m sure I don’t know how it works.
Just can’t wrap my head around why it worked the first time then it’s broken there after!

1 Like