Trouble with Makerverse setup w/ M2 2021

Hi bilzer046,

Thanks for your question. I assumed those errors would go away once I was able to finish the calibration process. Should they be going away one at a time as I enter the values?

-Aaron

Hi Orob,

Thanks for your continuing thoughts. I did the wipe with the same results. Nothing changed that I can discover. The z-axis doesn’t move either. I’ve seen the x & y motors move, but never the z.

Maybe I’ll try re-flashing the due board. It said it was successful the first time I did it, but I suppose it can’t hurt to try again. I followed the directions carefully, but maybe I did something wrong the first time.

Thanks again,

Aaron

Flash, wipe, reset home/chains, try calibration again… set up working size and enter measurements, then try to move sled with one hand on the power cord.

do you hear motor humming after the red reset button is pressed at the top? If not, you don’t have motor power.

Do you see garbage characters in the black terminal on the left when the system first turns on?

Hi dlang,

There’s only one power port that I can see on the exterior of the blue box. It’s on the top of the left side if you are looking at the box straight on with the words facing you. That orientation places the z-axis on the left side of the bottom face, and the x/y motor cable plugs on the center/right side of the bottom face. The USB plugs in on the same side as the 12v (the left face). There is a green connector on the right face, but I don’t have anything plugged into it. I assumed it was a test/programming connector for the due board. Where is the second plug location you are referring to?

Regards,

Aaron

Hi Orob,

No garbage characters when first powered on. I did see this once before I flashed it the first time. I’ll try reflashing and starting over from scratch.

I used to hear the slight humming from the motors back when I first started the calibration procedure. I was able to move the motors to the 12o’clock position, and then I spent time taking all the measurements. During that period the humming stopped. Since then I haven’t heard any humming.

Unfortunately, it will be this weekend before I’ll be able to get back to it. I’ll post my results and some picks of the plugs (assuming it doesn’t magically start working). In the meantime, if you (or anyone) has any more ideas of things to try once I’m able to get back to it, it is MUCH appreciated.

Thanks much,

Aaron

the humming will go until you put it to sleep. once asleep, you have to use the red reset button to wake it back up. It should start up at initial connection in the awake state. The humming really became a problem for me, but it is a good indicator of motor readiness. there is a wiki step by step here and here.

Gotcha. That’s good to know. I have no experience with this unit except what I’ve explained, so it’s really good to know what it SHOULD be doing. Thanks!

Hi Aaron,

I’m pretty sure I didn’t see those messages when I was stepping through the calibration. At the time, I summarized my experiences here (there’s a section on the calibration). I also used the tips from Maslow | Makerverse Docs. If memory serves me right the values were being saved as I stepped through each of the tabs.

Hope this helps you a bit.

Thanks everyone! It turns out that once I got a new brain (Arduino boards) from MakerMade I was able to get through the entire calibration process.

Unfortunately, I can’t get the Z-axis motor to respond at all! It doesn’t even try to move. I’ve disconnected and reconnected the cable multiple times. I made sure the power cord to the router wasn’t near the cord to motor… and the router power cord has yet to be plugged in anyway. I’ve power cycled the unit. I see the commands being sent and I see coordinates on the screen changing… but no hint of movement from the z-axis motor…

Any ideas?

is the z axis enabled in the settings?

Hi Orob,

Thanks for the quick response! Do you mean in this menu?


If so, then, unfortunately, yes. It was enabled already. If not in this menu, where?

-Aaron

look in the list of grbl settings below the black console window on the left side of the main page. There should be a list of settings. If you don’t see them, click on the word settings and they should expand downward. One of them should be z axis enable… $16 is “z axis attached” should be set to 1 or true. it should be right below maximum feed rate and above z encoder steps per revolution, which would be the next place to look.

There isn’t any $16 or “Z Axis Attached” listed. Nor do I see a “Maximum Feed Rate” nor “Z encoder steps.” When I hover over the labels, it counts up from $0 to $14 then skips to $21…

Is there another place to look for $16, etc? Is there a way to see the value using the console itself?

Mike at Makermade confirmed it’s a problem with either the motor or my cable… so hopefully the new ones they are sending will solve the issue.

Thanks for the help Orob (and others)! It is MUCH appreciated.

2 Likes

to answer your question, in the console you should be able to ask the controller what the $16 setting is by typing in $16 in the console and press enter. it should respond with that setting. If you don’t see anything then the software is filtering it off and trying to put it in a setting location.

Ok. So, MakerMade has now replaced the brains, my Z motor and the Z control cable. It all works! I was able to make my first cuts. YEAH! Thanks for the help.

Now, next issue (sorry to be a problem child). I’ve successfully installed the Makerverse web server on a fresh install of Raspberry Pi. The setup looks like this:

  • OS: raspios-bullseye-arm64-lite
  • Model: B3+

Note: I followed the installation instructions fastidiously. Nevertheless, it did NOT work right out of the box. I had to install NodeJS. I also had to modify the /home/{my login}/makerverse/bin/launch file to use /home/{my login}/ rather than home/**node** as the root directory for the install. Otherwise docker would throw an error every time I tried to launch the server. Once I did that, the webserver booted just fine. Awesome! I was then able to plug in the brains and I was able to connect up to it just fine! I spent a couple hours running the calibration and was able to get it under 3mm! Huzzah! Well, then I shut everything down, went to bed, and today when I came back to use my machine… lo and behold… no workspace! Nada! It’s like I did a fresh new install! I checked the logs (docker logs makerverse and the system logs with journalctl -xe) and no errors! In fact, the logs show it launching makerverse using home/{my login}/ as the root for the project. So… what the $@#(??? As a test I did a quick new setup. I then shut everything down, rebooted, and nada! No workspace again!

All that background to ask… So… How do I get the webserver to save the workspace?

Thanks tons (in advance)! This is going to be a sweet setup once I have it all working!

EDIT 01: I SFTP’d all the files from the RPi to my Windows laptop. I then did a comparison of the info in the .makerverse file from the RPi and the one on my desktop (from the standalone Makerverse app). They are vastly different. Here is the FULL text from the .makerverse I pulled from the RPi:

{
  "watchDirectory": "/home/node/gcode",
  "workspaces": [],
  "mountPoints": [
    {
      "route": "/tablet",
      "target": "/home/node/makerverse/widgets/cncjs-shopfloor-tablet/src/"
    }
  ],
  "state": {
      "checkForUpdates": true,
      "prereleases": false,
      "controller": {
          "exception": {
              "ignoreErrors": false
          }
      },
      "allowRemoteAccess": true
  },
  "commands": [
    {
      "id": "5b98d27e-79e7-4fcd-afbe-8de87b558df3",
      "mtime": 1600691535812,
      "enabled": true,
      "title": "Restart Makerverse",
      "commands": "pkill node"
    }
  ]
}

Note the /home/node/… references! There they are again! So, I modified this file, replacing every reference to “node” in filepaths with my profile name. I uploaded the file. Rebooted the RPi. Still same behavior. I keep using “cat .makerverse” to check if it ever gets modified… and nope! Never any changes to it. Also, please note the empty workspaces array ("workspaces": [],) The one on my PC has all the config data in the array for the setup I did using the standalone app on my laptop. So… why is it not getting saved on the RPi? Very curious…

EDIT 02: After thinking about this some more it dawned on me that I can keep searching for every reference to “node” in filepaths in every file in the makerverse install, or I can jump on the “home/node” bandwagon (so to speak). So, (not wanting to fully commit to creating a user login with the name “node”… because that’s just plain silly!) I added a symbolic link from /home/node pointing to /home/{my login}. The link works fine. I can cd /home/node and it will take me to /home/{my login}. I rebooted the RPi. The symbolic link is still there, but saving a workspace still doesn’t actually save anything. Still NO changes to .makerverse file! Now I’m really stuck!

1 Like

Sounds like you have a permissions issue in the folder where the .makerverse file is stored and it isn’t writing. You need to give the user running makerverse rights to write to that folder. Can you submit a ticket on the makerverse github page and describe the issue? Sounds like you having to install that stuff, the image needs to be rebuilt.

Hi Orob. Thanks for the response. That user (myself) is a member of the sudo users group same as was the user “pi”. There shouldn’t be any permissions issues. Maybe the docker container needs some additional permisions??? I followed the instructions on the website for making docker run as a priviledged client. I get no errors.

I’ll post on the Makerverse Github page also…

what is the node user doing you mention above? do you have write permissions to the /home/node folder? I vaguely recall this happening before, but I don’t remember the resolution, sorry I’m not able to provide more specific information.

There is no “node” user. But Makerverse has references to a /home/node filepath EVERYWHERE! For example. If I run docker container ls I see the following output for the makerverse container:

CONTAINER ID   IMAGE                    COMMAND                  CREATED          STATUS          PORTS                                       NAMES
99daca45d67a   makerverse/core:latest   "/home/node/bin/dock…"   37 minutes ago   Up 37 minutes   0.0.0.0:8000->8000/tcp, :::8000->8000/tcp   makerverse

Note the reference to the /home/node/bin/docker path… This is a problem. Or at least I think it is.