Maslow Home Maslow Community Garden Newsletter

Webcontrol Pi Dropping off Wifi

I have been using WebControl in a Raspberry Pi for a bit and loving how it works but have had multiple times of it dropping off the Wifi in the middle of a cut and can’t get it to recover? Any one else experience this or have any ideas of how to prevent it from happening. Copper will eventually get ran to the garage, just would like to get a bit more stable while working on getting the wire pulled.

Can you add a booster antenna to it? Does electrical noise mess up WiFi?
Not sure if that helps just thinking out loud?

1 Like

Does the cutting continue or does that stop?

The cutting continues but if the cut has a couple of different tools, I am unable to click resume after changing the tool (bit) in the router. I have often just resorted to power cycling the Pi and trying to get things to line up again but it is pretty hit or miss on getting that to work and getting the gc file home position to be exactly where it was before on the work surface.

I have considered using a WiFi extender and then plugging in the Ethernet from that to the Pi to see if it is something to do with the WiFi on the board. The Extender is likely to have a bit strong signal than the Pi itself as well. Ultimate goal is to get wire ran out to the garage to hopefully solve this but that will be a ways off.

I’ve had a wifi problem myself with my RPi. I don’t remember the issue, but the wifi adapter just stops working and I have to do a hard reset as well. I don’t think there’s anything going on with webcontrol that would cause this. The Ethernet adapter sounds like a good idea to try.

On a different topic, how does the tool change function work for you? I haven’t really tested it much.

As for the home position, when you reboot, does home position differ from where you had previously set it? It should save home to settings once you change it and then reload that value when it starts… at least that’s what was intended to happen.

Yeah, that is what seems like it going on. The wifi adapter just stops. It has nothing to do with WebControl.

Tool change has worked great. No issues as long as I am able to get to the web page and I remember to re-zero the z-axis.

After the hard reboot and web control comes back up it doesn’t have any record of what GC file was loaded and I have to re-open the file and I believe it is back at the default location. I will have to double check that though. As a work around I have taken note of the home position coordinates and then try to get them back to that by clicking around in the page and defining home. It would be a good feature if one could manually enter the coordinates for the home position.

Quick question… when you say GC file, do you mean your gcode file or your groundcontrol.ini file?

gcode file

ok… just making sure… I checked on my windows computer (don’t have access to an RPi at the moment) and my home setting persisted through restarts. Are there any other settings that don’t seem to persist?

Ok, I will try and check it this week to confirm. I am not aware of anything else that doesn’t persist. I did re-calibrate yesterday after the hard reboot as it just didn’t seem to be cutting quite as accurate as it had in the past. I will try to keep a closer eye on it though if the drops continue

Thanks. It’s weird that it doesn’t persist between reboots. And I don’t mean to be insulting by this question, but I just want to check… you are NOT reimporting your groundcontrol.ini file evertime you reboot, correct?

Yeah for sure, I am NOT re-importing the groundcontrol.ini file each time. The system boots and I click the start web control button to get going. That is all that is done when rebooting prior to loading the gcode file.

Ok… just checking (because that would have explained how home got reset). Did you setup SSH on your RPI? If so, you can view the webcontrol.json file located in the ~/.WebControl directory… it’s equivalent to groundcontrol.ini and when you define home, you can look at that file and make sure it writes it.

Yes, I did setup SSH on it. That is good to know. I will take a look at it and see what is in there. I haven’t had much time to explore the file structure on there yet, but I was planning to explore so that I can upload the gocode files to the file system on the backend while it is cutting.

maybe your WiFi access point has a short lease cycle and is dropping the connection and the rPi isn’t picking it back up. You could probably test this by having the rPi connected, then cycle power on your WiFi AP/Router and see if the rPi re-establishes the WiFi connection.

Another thing which might be happening is power saving/sleeping of the WiFi on the rPi. Try this:
sudo iw wlan0 set power_save off

I have the PI set with a Static IP. I don’t think it is lease time, as no other devices drop like this. I like the idea for the power save though. I will give this a try to see how it works. Thanks!

1 Like

I haven’t had an opportunity to try my RPi in a while, but it got so bad I put an alexa-enabled power switch on the RPi so I could remotely reboot it (machine is in the shed while I do development work in the house). got tired of walking out there to reboot it manually.

@madgrizzle, that is a great idea. I have a couple of Wemos that I can use for that. Definitely will be making use of that.

1 Like

Please report results as I just saw someone in our DIYRoboCar forum mentioned their rPi was dropping WiFi connections too. I’m concerned there might be a recent firmware update causing problems. I’ve already seen the PS3 bluetooth controller stop working and had to runs “sudo rpi-update” to get the latest kernel and firmware to fix that.