Will not respond

This system was bought and installed about December of 2019. Used it for a couple of projects and circumstances have left it idle ever since. Coming out of hibernation nothing will respond. I have uninstalled and reloaded Aduino and groundcontrol to no avail. Board is Arduino mega 2560 that I have since learned is obsolete. Have also downloaded and installed webcontrol to no avail. get a repeated communication error in Comm port 3. Do I need to upgrade to a new board?

Just a couple of things to try:

  1. Make sure both parts (the Arduino and the motor shield board) are securely connected to each other.
  2. Where do you have the power cord plugged in? IIRC, the power cord should be plugged into the top power connector (on the motor shield) not the Arduino.

I’d double check that to start with. Hopefully someone else comes up because after that, I would only be guessing.

1 Like

This is a GREAT suggestion. That’s a reasonable guess after coming out of storage.

What lights do you see when you plug it in?

Checked and are as you suggested. Nothing had been changed since it was ignored.

1 Like

What lights to do you see when you plug everything in? A picture might help us.

green light upper left corner and green light in lower right corner with installation on side and power and usb on right

I could be wrong because it’s been a long long time since I saw one of those, but that sounds right to me.

My bet would be some sort of USB driver issue with the Arduino Mega. I don’t think that you need to replace anything (it seems like software), but if you were to replace something it would be the Arduino Mega.

Is there another computer that you could try?

pictures. The Arduino does not respond to driver updates for the Mega. That is why I questioned if I need to upgrade

1 Like

Thank you so much for the help[. I have been working the forums and trying about anything not beyond my tech ability

1 Like

I think that this is the issue right here. It’s possible that there is some issue with the Mega itself, but that’s unlikely. Is there any way to try it on a different computer? You only need the Arduino and the USB cord to check.

coming off a laptop in the shop and only other computer would be desktop in the house. Beginning to look like I would be better off on many fronts to upgrade.

1 Like

Maslow4 is a pretty massive upgrade in every way. That being said I don’t think that there is anything wrong with your machine physically. That sounds like a USB drivers thing to me. You could see if MakerMade will send you a new Mega just to test, but it’s your call :smiley:

@rivrat430 Where are you located? I am waiting on my M4 (should be in the first group) and have a few projects lined up first, so unless you are just itching to upgrade, I could probably send you the one I have. I know it works and could at least use this to test to see if it is your Arduino.

1 Like

What operating system are you using. I first tried Linux (Ubuntu) and had alot of difficulties connecting (even though wireless mouse etc would connect). I would try different ports/USB cable/computer first. Borrow a friend’s windows laptop if you must.

1 Like

I am using Windows 10 operating system. Live in west central Illinois. I have tried every USB port available thinking one connection might not be as friendly. Also have replaced the USb cable between the board and the laptop. As a result of these conversations I am focusing on USB drivers for now. Thanks again.

1 Like

I wonder if you need to roll back the USB driver. What com ports are showing up? If you unplug and replug the mega. Does windows give the USB plug sound that it is enumerating a USB device?

The mega is pretty durable. You can pick one up off Amazon for <$20 last I checked (which was a while ago). Blow the dust off of it. It should still work.

1 Like

Possibly a shield issue that needs to be addressed if you have communication, but the motors are not spinning. Power seems to be going through. Windows COM Port issues could be problematic if you recently upgraded to Windows 10/11 with the latest security patches. The same with driver issues. Contact us to open a support ticket at info@makermade.com and reference this thread so Joel or Xavier can see what you have done. Specifically, ask for Joel or Xavier in your support request and let them know you came from the Maslow forums with the link back to this page.

1 Like