Z axis lowers while X,Y axis is moving

The Z axis lowers into the material while the X,Y axis’s are moving. I am attempting to calibrate this yet again. During the test pattern test at the end of the calibration process the Z axis extends into he material while the sled is moving toward the first corner cut. It keeps extending/plunging until the router bottoms out. The Z should not even move until the sled gets to the first cut position.

Also as a separate issue, or it could be related, (this sometimes happens) when calibrating the Z axis, I set the bit to just touching the material. I then press “Define zero” The Z axis then retracts a few mm. When I go to mill a file, the Z retracts again a few mm. When the sled moves to the first cut position, the Z axis extends back a few mm but does not extend the full length of the total retraction so it cuts air.

Why is this doing this? I took out firmware version 1.12 and put in 1.11 and GC 1.11 and still have the same issue.

I don’t know why it would be doing that… but if this started happening after you upgraded to 1.12 then I would try wiping the eeprom prior to loading a version of firmware.

I had some z-axis weirdness when I upgraded from 1.04 to 1.08 (when .08 first came out) and that weirdness persisted when I tried to go back to 1.04; I fixed it by wiping the eeprom, loading 1.04 and recalibrated.

I’d try wiping the eeprom prior to loading 1.12 and see if that fixes it.

first off, are you sure you have the tension in the latch set correctly and the
latch closed while you are operating?

can you post a video of what’s happening?

How do I wipe the eprom?

dlang, I’m not sure I understand. Yes, the latch is closed and adjusted (I’m assuming your talking about the latch one the router base). What I mean a when I describe the Z axis lowering during X,Y movement, I mean that the Z axis motor is turning and feeding the router into the material. The router is not lowering because it is loose.

Hope that clears it up.

In Ground Control; select Actions > Advanced > Wipe EEPROM

If the Z axis is rotating while you are moving, we need tolook at the g-code and
figure out what it’s being told to do.

It could be bad g-code, it could be a bug in the maslow interpreting the g-code

OK…I was using the calibration test in GC. So, what ever that G-code is.

OH…thats easy!

I wiped the eeprom. reloaded in firmware 1.11. I went through the calibration steps. When I ran the test pattern and got my measurements, I attempted to enter the setting but got an error something about the measurements not working or not being acceptable. I forgot the exact wording. I ran the test pattern again, entered the results and got the same error message.

I then ran the mtn.nc file I got from Bar. It seemed to run ok except it wanted to make 4 passes that at the 3rd pass had already bottomed out the router. So, I wonder if that is just a file issue and not really a Maslow issue.

Does anyone have a simple File that I can setup the milling process myself for a 5/8" stock? Something simple that will also test the machine.

Thanks for your help.

I just had a similar issue to this, not sure if I should start a new thread or continue this one.

I was trying to cut out the first sled, and the maslow isn’t always waiting for the z axis to come to position before moving x-y. A few times it was moving at +.1 instead of the +.5 saftey height, but right after it cut out the profile for the inner circle, it moved to cut the outer circle and left the bit at about -.5, dragging a huge cut into what would have been the sled.

Any ideas what might be causing it if it isn’t eeprom?

1 Like

I would suggest to open a new topic as this is not marked solved and might be relatete to FW/GC 1.11 and I hope you are at 1.18.
Makeing a new topic will give you more attention then a in a 4 months old one.

Read this https://github.com/MaslowCommunityGarden/Inexpensive-add-ons-for-z-axis-slack-imprecision/blob/master/INSTRUCTIONS.md and add the FW/GC version you are running, if you are using the riggid router, upload the .nc file. With this essential information you will get help.
Regards, Gero

1 Like