Z Depth + Ridgid Problems [RESOLVED]

I’m having an issue with the Z-Depth of my Maslow. I’m using a Ridgid R29303 (Which is the same as the R22002 but with a plunge base included). When I cut the motor will plunge and raise, but the spring toggle pops out of the groove in the router and loses the position. Coupled with an X/Y movement, and I get gouges into the plywood.

  • Tried the bungee cord method
  • Tried adding a large hose clamp to the spring release to keep it pressed in.
  • Also backed off the nut on the mount clamp.
  • Greased the mount.

Has anyone else experienced this? It’s a new router, so I’d imagine the spring release isn’t terribly worn. Looking for ways to fix the issue so I can make my first successful cut. Thanks in advance!

Not sure if its the problem, but check wiki under “not cutting to full depth”

1 Like

Thanks for this, I’ll check this tonight. Was fairly certain there was no collision happening, but the description is exactly what I’m experiencing.

i think you want this post.

When I was researching this: Cheap fixes for z-axis slop on the Ridgid R22002

I found that an improperly lubricated worm shaft could lighten the tab’s grip in the router body when it rotated counter-clockwise. The drag between the clip and the worm was more than the spring could handle.


Status: Rotated the Z-Axis motor today, and reconnected the flex shaft to make sure everything was tight. Tested in a vertical position and the motor jammed up and couldn’t move the router. The new position doesn’t seem to have any collision with the router housing. Spring still releases under tension. I’ll work on it more tonight.

1 Like

Managed to record the issue, sorry for the shaky cam. I’m seeing the same issues as in this post (Cheap fixes for z-axis slop on the Ridgid R22002) but I don’t think I’m at the point where I should fix that. Greased the worm gear, and found a set screw that had come loose. Still no fix.

A couple things.

  1. In this video do you have the bungee cord over the top of the router?
    If so I think it is applying too much pressure to the router. I saw similar behavior when I was using a bungee cord and I switched to 3 x #10 rubber bands on each side. As you know, the more you stretch the bungee the more force it is applying and at some point a bungee cord actually stops being stretchy and simply becomes a rope. From the looks of it, you are “hitting” a specific point where the locking tab catches and pops out.

  2. Have you inspected the inside of the router base? Specficially the anti rotation groove?
    In my router and on many others, the groove that is cast into the base, where a corresponding nub on the motor body rides, is very poorly machined. On my router I noticed not only a varying width of the slot but also a varying depth. I spent about 15 minutes with a few files to make that groove as straight as possible and a constant depth. If yours is as bad as mine was you will actually see evidence of the nub rubbing on the high spots of the groove.

  3. Related to #1 and #2 above, do you see an increased deflection in the locking tab right before the locking tab pops out? In other words does the locking tab start to tilt down more?
    If so, it would tend to indicate that you are encountering a change in resistance which could be the bungee getting too tight OR it could be the nub to groove interaction OR even some other variation in the router base. My router base was ever so slightly conical and some strips of UHMW tape inside the base freed it up enough to ride smoothly.

The one thing I would suggest, even if you don’t make the locking tab mod is to put that washer under the threaded rod. It will help overall and won’t take much time to do.


Did the router drop on its own?

Idea: tighten the housing’s grip on the router so it can still move, but not go crooked in the housing? Maybe the router is dragging up with no resistance but is going crooked on the way down, led by the mechanical fuse’s tab.

The tab lets go, the pressure on the far side wall is gone, and the router can fall free?

Would likely mean the far-side tab isn’t sliding well either.

1 Like

Thanks so much for the awesome suggestions!

@arnoldcp (1) I didn’t use any bungee cords on this test, I have the attached to the router, but I figured it was plunging fine on its own. (2) I’ve attached a photo of the anti-rotation groove, and I’m pretty sure you are correct, you can see where the tab is rubbing about halfway down and there’s a disjoint between the top and the bottom. I’ve started filing and I’ll test again once I’ve got things assembled this weekend. (3) Yes to the deflection.

@geeklimit I’ve tightened the housing grip, and I’ll test to see that the motor continues to move smoothly after I file down the anti-rotation channel.

Again, thanks for the suggestions! I’ll report back over the weekend.


That is exactly what I was seeing, I bet that your filing makes at least some improvement for you.

I have to say I am actually very surprised that Ridgid has not addressed this issue, i understand that we are asking for more precision than the router was meant to provide but, this router is set up for being using under a router table and has a “micro-adjustment” system. Of the anti rotation groove causes binding, the “micro-adjustment” knob is not going to work properly…CNC or No CNC. Just very sloppy.


Ok, filed down the anti-rotation channel, greased the housing, added a washer in the worm gear assembly, and tightened the housing clamp to be as tight as possible but still let the router slide. Managed to get the z-axis to slide up and down about 20 times without issue. Thanks everyone for your suggestions!


Hello, sorry for my bad English. Newbie AND French, I’m moving slowly, but I’m still moving :wink:
Calibration is not as difficult as I feared, and I was very impressed when measuring distance between 1-2 and 3-4, and found 1914mm for both!! but the Ridgid router with the Z-axis engine seems to be causing me the same problems as yours, @eightlines. It loses its zero point because the router is coming out of its lock slot. I made a video here:
I think I do not need for the moment to change the sacrificial orange button.
I did not install yet bungee cords or tensioner to my Ridgid (AEG in France), but will do.
I’m not sure I understand your solution, especially when you write that you have “tightened the housing clamp to be as tight as possible”, when I also read “the clasp needs to be loosened” in another post, here:

Can you please send a photo with arrows that shows your intervention to the different points on the Ridgid? (the best would be a video, even with shaky cam, as I did myself) :slight_smile:

1 Like

@Didier, in your video it looks like the router housing clamp is too tight.

in summary, you want the clasp closed, but you want the router to easily move ‘up and down’ (ie: deeper/shallower cuts) in the housing without being able to move in any other direction.

you will want to clean/polish as best you can, the router housing and the router barrel. The smoother their surfaces are, the more pressure you can apply with the housing, keeping the router firmly in place while still allowing the router to move when asked to.

also check the wiki for some other tips to keep the router height adjustment screw in place and precise in its movement.

hope this helps,

1 Like

Thank you, @mrfugu. So I will undo the clasp and clean/polish router housing & router barrel, install a bungee cord, then test again. If nothing changes, I shall go to the wiki for other tips, and maybe open the gear assembly to check orange button.
I was cutting the final sled, but my Maslow could only cut the first hole, then nothing more, because of that problem.