Zaxis motor does not respond to commands

I think I am doing all the right things,but I have not been able to move my z axis motor. My son who works on maintaining computer programs for the government helped me get my x and y motors calibrated.There is one thing that he did while helping me that may be causing a problem. At one point,and I don’t remember where, he got an error message indicating that the software could not find a particular jpeg file that it was looking for, as a work around he took another jpeg file and changed it’s name to the name of the missing file . This allowed him to get past the error message and eventually he got the x and y motors calibrated. This was probably at least a month ago. Neither of us can remember exactly what the file was or even where we were in the procedures. Please recommend a starting point from which I an repeat the procedures and find my a axis motor problem.

Well, the jpeg image, whatever it is, shouldn’t be causing any issues.

When you run “Test Motors/Encoders” under the Actions page, what do you get?

1 Like

There was an issue that affected Linux systems with an earlier version of GroundControl. The JPG extension called for in the python program didn’t match the case of the jpg extension of the files (or vice versa?). We thought that we had identified all the instances of this and correct them. Are you using the current release v1.19 of GroundControl?

I think I have version 1.10 of ground control.

1 Like

The JPG fix was in v1.11 :grin:
I’d recommend you update GC and firmware to v1.18 (not v1.19, there’s a bug in that one with a fix that hasn’t been released yet). There have been some good improvements since v1.10!


I agree that this is the place to start. Is the z-axis enabled under the settings?