Maslow Home Maslow Community Garden Newsletter

Chain sag correction value 0

Ok this is my 8th run at calibration. I finally got some traction and reached the last step of the test cuts and inputting the measurements. After the test cuts were made, I realized that the cuts were really light. They didn’t go all the way through, just a light indentation. Assuming this has to do with my bungee, I continued with the measurements figuring I would fix the router depth issue later.

Once I put the measurements in, I get an error that says “machine could not be calibrated. Please check your workspace dimensions”. Assuming I missed a step, I went through the entire process again. Same thing.

One thing I noticed is that during every calibration, the “chain sag correction value” is 0. Every time. Surely this is not correct? Is this why it is not able to calibrate?

Another issue is that on my 9th and most recent calibration, when I ran the “pull chain tight” step, I don’t hear a beep anymore like I used to, and the chain doesn’t stop pulling and bends my top bar. This did not happen before. I am quite lost as this was not an issue with my previous 8 calibrations.

I have recently updated the firmware as well, so I am running current there.

Any guidance would be greatly appreciated. I am determined to get this figured out!

Are you using Holey Calibration (i.e., from @joshua’s fork)?

I don’t think this is the issue. A value of zero just means that no chain correction is applied which shouldn’t have a negative impact. That values is computed by the last step where the marks are measured and so it should be zero until you complete a calibration run.

This is more concerning to me. I saw that the latest firmware made changes to how some of the code in this area is done. Can anyone else confirm that they are able to calibrate normally with the latest firmware?

I think the problem was specific to the holey calibration fork, that’s why I was asking.

1 Like

I am not using Holey Calibration. Is this something I need to do?

No, but we recently found a problem in holey calibration where the chain wouldn’t go slack during the measuring distance between motors. There’s a firmware update that I think ensures that it stops pulling… are you running v1.27? Was released last week I think.

Yes I am running 1.27

I don’t know what would be causing this if you are running both groundcontrol v1.27 and the arduino firmware v1.27. The “pull chain tight” step sends a command to the left motor to turn on full speed (counterclockwise) to pull on the chain. When it’s done, it turns off the left motor. I’m a bit stumped as to why you would see this behavior with the latest fixes.

Are you also running ground control v1.27?

Yes I made sure to update both.

If there is someway you can share your log.txt file, that would help greatly. It’s likely huge and you can’t readily paste it in a thread.

I suspect the chain sag of 0 and the chain pull are somehow related…

Ok. Can you tell me how to access this? I apologize, I am completely new to this.

it should be in the directory where you run groundcontrol.

the bug of not stopping the pull was there for a long time, holey just added
another bug (affecting logging) that made it common to hit the first one.

David Lang

Correct.

remember that the version number was changed a week or so before the release,
when did you pull the 1.27 firmware?

David Lang

I updated this past weekend. I think it was Saturday evening? So just a few days ago

Thanks for emailing the log. I don’t see in the log where the machine failed to stop pulling during the distance measurement. Every B11 (pull tight) was followed by a B10 (give slack) so let’s put that aside for the moment.

I see where the calibration values are being pushed, but only the values you entered are being sent, versus values that are being optimized. In the calibration page, when you enter your measurements between cut and press Enter Values, do you get an error message at all?

Yes, it gives me the “machine could not be calibrated. Please check your work area dimensions”. So I did what was recommended before in one of the forums, and manually entered my values. Still with the same error.