Onshape to dxf help

I’m embarrassed to ask this thus me putting it in the no judgement section! I’m new to all of this cad/cam/cnc stuff. I’m trying to make the tablet holder that Bar made on onshape. However I cannot figure out how to export it to a dxf file. I can handle the converting process. I just need help finding the dang button to create a dxf! Any help is greatly appreciated!

Nothing embarrassing to be new to something. Respect you are starting! Can’t help on this one, onshape is new for me also. The question was interesting enough to search and play around. (Might want that thing myself one day)
Sketches can be exported to DWG and DXF formats
Planar faces can be exported to DWG and DXF formats
Flattened views of sheet metal models can be exported to DWG and DXF formats
The last 2 I could not figure out. A ‘right-click’ on sketches does export, but it’s missing the extrusion and fillet, so not really useful. Eager to see more responds here. Perhaps exporting to something else first?

Try a ‘right-click’ on the >Tablet Holder Parts To Cut< tab. Chose export.

Result in QCAD:

Found Im- and Export covered here:


you may want to play around with adding the kiri:moto app to your onshape
config, it lets you take the objects that you’ve created in onshape and create
the g-code to make them (3d printer, CNC mill, or laser cutter cutting slices)

David Lang

I have a system that I came up with that took a while. Here’s what I do.

First I save all the parts of the project in a drawing file and export it as a dxf file by right clicking on it:

Use release version 13 or older so that inkscape can open the file;

Then I open the file in inkscape without messing with any of the default settings and save it as a .svg file:


Then I change the SVG import default resolution in MakerCAM to 96 before importing the file to make sure everything imports the correct size

It’s not the best system ever, but it seems to constantly get me parts which are the right size


Is it 96 because your sheet is set to 1/8" = 1’-0"?

1 Like

Thanks Bar and everyone! That worked perfect!


@chauhuh I try to always set the sheet to 1:1, I really have no idea where the 96 comes from. Does anyone else know?

I think it’s the dpi for inkscape. For Illustrator you might need to change that to 72. "Old Inkspape prior 0.92 had 90 dpi.

1 Like

So, can anybody help with this process?

Have the design in Onshape… add it to a Part, export as DXF, open in Inkscape.

And it’s just blank.

I’m missing the obvious somewhere :slight_smile:

you cannot take a 3D part in onshape and export it as a 2D file.

But you can take a 2D sketch in onshape and export it as a 2D file. Select the
sketch, not the part, right click and you will see export as dxf.

why are you looking to open it in inkscape?


I said it wrong… I added the part to a drawing, exported as DXF (version 13), etc.

I was just following @bar’s recommended (or at least functional for him) method for getting to SVG to use with MakerCAM (in the post above).

Since my post I’ve been attempting to play with Kiri:Moto and can kind of see getting that working, maybe, although getting it to just cut out a hole as opposed to “removing the entire area a thin layer at a time” I haven’t found yet.

I’ve had what you are describing happen. I think it’s because Inkscape isn’t designed to handle such big parts so the default canvas is just a 4"x8" sheet of paper. When you zoom way out to see if the parts are there, you still can’t see them because the lines are so thin :roll_eyes:

Try clicking and dragging a box around them to select everything, I’ve had that make it so I can tell they are there

Well, right you are as usual :slight_smile: - or at least you got me headed in the right direction…

The default “page size” does seem to be a sheet of paper… and now I’ve found my “part” - it’s just that it is so microscopically small that I couldn’t see it.

I’ll have to play with this some more to figure out why it’s coming in at like 8 mm instead of 14" or whatever.

That’s the direction we want to go!

I’d play around with these settings:


Which appear for me when I do file -> Open on a .dxf file

I’ve had good luck using both Manual scale and Read from file

Yeah, was just trying the “Read from file” which seems much more reasonable…

Thanks for the pointer (and thanks @dlang for chiming in also!).

I figured you already knew that, but I had inkscape open already so it was temptingly easy to grab the screenshot

you probably exported as inches (or worse) and imported as mm

David Lang

Good thought… you may very well be right. I’ll look at that, thanks.

1 Like

OK, I’m sorry, but if anybody has other ideas…

I select the part in Onshape… right-click and use ‘Create drawing of…’

I export the Drawing as a DXF.

I can open it in Inkscape (and find it now, thanks!)

I save it into SVG and open in makercad

And it’s a shade less than 6" across (should be 18").

In the same Onshape I took the 6" sample square that was already there and do the same process and it comes out right.

I’m not sure if there is some weird scaling going on due to the part being larger than the “paper” somewhere along the way, or what.

I finally seemed to have gotten it to work if I transform it in Inkscape, increasing the scale x10 (from 100% to 1000%).

All of this is based on the other Onshape design by David Walsh (sorry David, not trying to take credit for anything… I just took your sled and modified holes around for the linkage stuff).

Dunno what I’m missing…