Maslow Home Maslow Community Garden

Ground Control message continually toggles from "Connected" to "Not Connected"


To clarify

You have now been able to upload the firmware using com3?

What version of the firmware are you on?

Can you send a screen capture of what it looks like from Ground Control opening?

Thank you


mega 2560 r3 don’t know if this matters but I connected a bluetooth logitch keyboard and mouse to one of the usb openings plus a Wi-Fi usb to my network


To one of the USB ports on the Arduino or on the computer? Can you send a picture of the Arduino? There should only be one USB opening


to my computer, there is only one usb opening on the Arduino, you still want to see a pic?


Ok, that shouldn’t matter. As long as you are sure of the COM port



btw the numbers are still running


I think that might be the issue. The Arduino IDE (with the numbers going) needs to be closed before Ground Control will be able to connect.

The firmware also needs to be re-installed because right now the Arduino is running that test program which just prints numbers


ok …should I start from scratch again and uninstall gc and ide first


I don’t think you need to, but it sounds like a good idea just so we have a fresh start


will do…will report what happens thanks for your help


We may have overlooked a very simple step -

This is from another post:

Make sure you have plugged to power into the shield and not the Arduino -

@Scotty your post picture is appreciated.

Thank you


ok started over but this time a get a error message

I’m almost ready to give up!!!


If you click the “copy error message” button it will let you copy and past the error message which could help is figure out where the issue is


this is the whole screen


Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

C:\Users\Gary\AppData\Local\Temp\\Firmware-1.10\cnc_ctrl_v1\cnc_ctrl_v1.ino:33:20: fatal error: Maslow.h: No such file or directory

#include “Maslow.h”


compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.


Got it!

The firmware is actually all the files in that download, not just the .in file so you need the whole folder. If the cncctrlv1.ini file isn’t in the folder with the other files they can’t be found


sorry Bar don’t know what that all means


Got it.

The easiest solution is to delete the firmware folder that you have and download it again, unzip it, then do file -> open from within the Arduino program


just did that and it looks like it took, now I’m going to install ground control again an d see what happens