GroundControl Crash on File Opening

Hi there!

My Ground Control sometimes crashes when I try to open a G-Code file.
I create them all with Fusion 360.
Some work fine and some don’t.
Is there an Error log somewhere or can Fusion write Code, that CroundControl can*t handle?

Laptop with WIn 7
GC 1.09 and Firmware 1.09

I would add the File, but I’m not allowed to…


Hmmm having the file would help me to figure out what’s going on.

There isn’t a log of what works and what doesnt, but the general policy is that if you find something which doesn’t work and send me the file I will make it work in the next release.

Using the Maslow post processor is a good idea if you are not

1 Like

There is a log named ‘log.txt’. The location depends on the operating system:
Linux: in the GroundControl folder that you run from
Windows: in the ‘GroundControl-Windows.Portable.v1.xx\GroundControl\’ folder
OSX: in Finder, in the Applications folder, find the groundcontrol app, right-click on it and ‘Show Package Contents’ to open a window that lets you navigate to the right place. The GroundControl log file is in the ‘Contents/Resources/yourapp/’ folder.

I’m not sure of the restrictions, I think that new accounts are restricted from uploading for one day, but it could be less. Only some file types are allowed, you could try zipping it, the .zip file is allowed. I think .txt and .nc are allowed as well.

Which operating system are you using? I’ve not used Fusion to create a gcode file, but others here have. If I remember right, choosing the ‘grbl’ post processor from the list made files that worked. Which one did you use?


Here’s a way to find out more. If you can replace the “Launch Ground Control” file with the one in this zip (178 Bytes) Ground Control will pause after crashing so we can see what the error message is!


I finally fount the time to check back on my (not really) broken G-Code and - Man, do I feel stupid now!-
Fount out, Ground Control doesn’t like blank spaces in filenames…
So, problem solved!
Thanks for the suggestions anyways!


That still sounds like a bug to me!

Would you be willing to post the file which was giving you trouble so I can fix the issue? I’d like for Ground Control to not crash ever :grin:

I tried just adding spaces to a file name and I couldn’t make it crash that way

1 Like

Bar, the OS would be nice :wink:
On Ubuntu Mate 18.04 LTS

do not cause GC1.12 to crash.
Edit: FW/GC 1.13 is also fine with blanks.

1 Like

Great point @gero this was on Windows 10

1 Like

OSX HighSierra works OK on an .nc file with a space in the name for me.

GC does crash if I put a space in its name, though…

1 Like

I’m not sure, if the Filename was the problem, and right now I’m completely unable to check because about 1 hour after my last post, the whole crappy AEG-Router went up in flames!
It took my Z-Axis Motor and its cable with it. So bye bye CNC for now…
But I can at least attach the File here:
Untersetzer 6mm-8mm Fräser-Ohne (800 Bytes)

1 Like

Wow! That is quite frightening! Are you sure that the router was the issue? What happened?

I can’t think of anything else.
The machine was running and I went into the house to help my daughter who has a broken Arm at the moment.
A bit later I was surprised that it was so quiet in the shop, went out and the whole sled was already gone…
Unplugged everything and got the garden hose (hope, that’s the right Word)…

I add some Photos:

1 Like

WOW. That’s a real fire.

I’m really glad you caught it so quickly.

My instinct wouldn’t be to blame the router. An electric motor is not very likely to catch fire and they are very well tested. The router bit against the wood would be my guess. The friction of a dull bit against the wood, or if the bit is not moving can create friction and heat which can start a fire.

Would it be OK if we use your pictures in the next newsletter to remind folks to never leaver the machine running untended?


It’s possible that the router stopped moving (for whatever reason) and the
friction of the spinning bit against the wood ignited the chips/sawdust.

This is more likely than the router itself catching on fire.

looking at the picture, the router is mostly damaged at the base, while the part
of the router that has power and could start a fire is at the top.

So I would say this is FAR more likely to be a matter of the bit friction
triggering a fire.

Feel free to use the pictures!



I was suspecting the → ä ← in the filename, but on ubuntu it does not crash GC.
The Bier-Untersetzer file runs well on my GC Maslow simulator. Prost!

If I remember right when you get the lost USB connection error the machine just freezes (with the bit still embedded). Would be nice if certain error codes forced the Z-axis to the safety height.

1 Like

I only tried on Windows machines.
Win 7 and GC 1.09
Win 10 and GC 1.13
No luck on both Computers.

I got it to crash! :joy::rofl::joy::rofl::joy:
It is the → ä ←

Python error: UnicodeEncodeError: ‘ascii’ codec can’t encode character u’\xe4’ in position 54: ordinal not in range(128)

Surprising for me is that it did not crash the first time

1 Like

Very sorry about your troubles.

Kivy on OSX doesn’t like the “ä” character combination. The OS and most applicatins seem to accept it, but Kivy posts this error:

   File "/Applications/", line 92, in load'Maslow Settings', 'openFile', str(
 UnicodeEncodeError: 'ascii' codec can't encode characters in position 58-59: ordinal not in range(128)